Issues on Razer Blade Pro 17 (Early 2020(

Hi, I just bought Zorin OS Pro today, really fell in love with the Distro and I want to make this my daily driver. So far everything has been much friendlier than on Ubuntu however I have a couple issues:

  1. Brightness control isn't working, I can move the slider on the menu or use the function keys and the UI will work correctly but the brightness won't change, I tried rebooting but no luck, any ideas how to fix this and get the brightness control to work?

  2. Pinch to zoom on the touchpad doesn't work on any browser (tried chrome, brave, firefox) any idea why?

Thanks in advance

You might try this suggestion:

What computer make and model are you using?

Razer Blade Pro 17 (early 2020) model

This apapanda tool worked, however it's a clumsy solution, why doesn't the OS brightness control just work normally?

In that case, can you please try this possible fix here:

Looking into Pinch to zoom (not a feature that I use) seems a lesson in disappointment.
Not much support for it on Linux systems. Toward the end of the thread, a user links to a github project on this; I have never tested this:

Tried it but didn't work, guess I'll use the apapapanda tool for now. Is this the case with all laptops using this distro or is it just a few?

Also I read that this distro supported pinch to zoom on browsers with the touchpad, am I unlucky or maybe what I was wrong and the distro doesn't support that?

Where did you read this?

No, just a few. And any Linux Distro can run into these types of incompatibilities. You may try another distro and have that function working, if that developer has figured out a way. You may not. I know that on many distro forums, such questions as these are common questions, which suggests it is Linux as a whole.

Something to remember:
Manufacturers of components are trying to generate profit. In actuality, many of the programs needed to work properly with the manufacturers hardware are proprietary. In general, these are not folks that support Free Open Source.
There are a few that do. Many do not.
Linux developers then must work backward, tracing out how the drivers work, then engineering ones for Linux.
You can easily imagine how even a small change in one particular manufacturers code can throw off drivers that work in a very similar but different makers machine.
Manufacturers generally sell with Windows OS in mind or even with Windows OS installed - which means they can charge you more for having that OS on there. This preferential treatment is again - all about the money.

For the majority of users, things work fine. Which is why the forum is not overrun and inundated with help requests. But there are a lot of manufacturers out there, all preferring that they get a bigger piece of the pie.
We, the users, ultimately draw the short straw. In spite of being the supplier of the funding, as a whole (buying the computer), we are a target to take advantage of, rather than being the one doing the paying and worked for.

I am not a software engineer, just a member of the forum that tries to be helpful. It is frustrating at times when a new user joins with an issue that I do not know how to solve. And while I try to learn as I go sometimes, there are limits.

On my computer, an 11th gen i5 with Nvidia 3060, literally every single thing worked on Zorin install, right out of the box. This is my usual case; I rarely need to troubleshoot and the vast majority of troubleshooting I do, I do for other people on this forum. Even so, it is worth it to me to be rid of the extreme Controlling Nature of Microsoft to troubleshoot some minor issues. On Windows, I often was troubleshooting major issues, with the most unhelpful tech support found across the land.

Here they clearly state it so I'm confused:

  • Pinch with 2 fingers to zoom in and out of content. This works in the Document Viewer app, as well as the Firefox and Google Chrome / Chromium web browsers.

For the rest, I understand your points and I appreciate the help, I'm thinking of maybe buying a Tuxedo laptop or the Starbook however I see many hardware compromises on these linux native laptops like no touchscreen, bad webcams, no 120hz etc. I understand most people that use linux use mid tier or cheaper laptops, fortunately I can afford premium notebooks and I haven't found a linux native one without compromise, any recommendations would be appreciated.

Thanks in advance

1 Like

It does, indeed.
It says these are not available on Zorin Lite, which suggests this is a Gnome Desktop thing.
Perhaps a Gnome-extension...

Any of the Forum Gnome users know? @swarfendor437 ?
@Storm

Looks like it only works with Wayland! D'OH!

And possibly old litigation issues on its patents?

Hi swarfendor437 I appreciate your response. Could you explain a bit further what you mean by Wayland? how do I activate that? Any idea why the Zorin website says the gesture comes with it then, if it depends on some wayland thing that's not really part of the distro?

Wayland is a Desktop Environment - if you log out from a session you should see a cog to bottom right of screen - click on it and see if Zorin on Wayland is present. I have tried installing VM to virtual disk but I am running out of space on this drive so couldn't test.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.