Issues with 2015 MacBook Air Zorin OS 16 Wake From Sleep

Zorin OS runs like a dream on this machine. Arguably snappier and smoother than the original Yosemite os x. The only problem is, I'm having some issues I can't seem to resolve. The internal speaker doesn't work, and there is no Bluetooth adapter recognized. I am also noticing that when I close the clamshell laptop to sleep when I open it back up to use it again, no input works, forcing me to restart. I'm really new to Linux and have been using chatGPT and Reddit for suggestions. Any advice is appreciated.

It is preferable to separate issues into separate threads. It may seem counter-intuitive to open multiple threads at once. But what it boils down to is the forum as a resource to locate Solutions. Having three solutions in one thread makes that very difficult.
So let's grab at random:

Since you tried searching for an answer, we are not sure what you have already tried. Please be patient with any suggestions we offer that you have tried already.
Can you confirm if you are using an nVME SSD on the machine?

Next step:

sudo nano /etc/systemd/logind.conf

Arrow key down to #HandleLidSwitch=suspend and remove the hashtag at the front. The hashtag (#) tells the system to ignore that line. Tap ctrl+o to overwrite. Then enter to save current configuration. Then ctrl+x to exit the editor.
Now, you must run:

systemctl restart systemd-logind.service

If no good, try changing "suspend" to "Ignore"
Repeat the steps to overwrite, save and close, then run the restart of systemd-logind.service again and test.

Thanks @Aravisian this machine is equipped with a PCIe SSD. I'm trying your suggested edits now, HandleLidSwitch=suspend did not work, but I am now trying the ignore option. If it helps with your suggestions, when the machine falls asleep while the clamshell is open, I am able to use the keyboard and trackpad to wake it. when I close the clamshell, however, this is when I lose input.

Hmmm, nVME SSD can be used in PCI Express.
I ask about this specifically as there is a known (And currently unsolved bug) with nVME on Wake From Sleep.

setting the handlelid to ignore is an acceptable solution to me. the machine stays on after closing the clamshell until its automatic sleep trigger after inactivity, This allows me to continue using input as long as i dont lock the machine.

Do you happen to know any solution for the internal speaker? I double checked Alsamixer already and nothing is muted. Further, I downloaded pulseaudiovolume control and checked the default device. The system recognizes when sound should be playing on pulseaudio, no sound is coming out though. re-installing the audio drivers also did not fix this for me

Let's go ahead and start two new threads for each of your separate issues.

Done, Thanks again

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.