Issues with multiple key presses in games

I recently installed Zorin and, when playing Minecraft, I noticed that if I press two keys at the same time it doesn’t do anything for a while (half a second or so) and then does the action. With three keys at the same time, one registers instantly and the other two half a second later. I have a Trust keyboard, this issue has never happened on Windows.
Another issue is that if I press “t” to open chat it sometimes also says “t” in the chat instead of just opening it with no text.
How can I solve this issue?

Hi, System64.
Do you have this occur with any other application or game?
I wonder if that is a lag from resources being maxed. Have System Monitor (Zorin menu -> Utilities) running during the game, then click the Resources tab and see how much RAM and CPU is being used while the game is running.
I also recommend trying another keyboard to see if the issue replicates - another factor you can try to eliminate.
Finally, there are some suggestions here, including switching to Wayland desktop:

It doesn’t seem to happen when typing. I discovered however that one keypress is immediately registered, while the other is delayed. This is only when pressing two keys at the same time. I’ve tried switching USB port, I’ve also tried other keyboards, but the problem is still here. I’ve tried the solutions on the link, but they all mention input lag, while I have no input lag except when I specifically press two keys at the same exact time, and one registers immediately while the other registers after half a second.