Issues with rclone, google drive & ZorinOS Lite. Need help

Now my only issues are:
1.) that when I explore my mounted & streamed google drive, the video & picture thumbnails arent loading, so it makes it very hard to see & navigate thru the thumbnails(photos/videos).
Also, when i click open my photos they open up okay,
But when i click on any video file, for example .mp4 or .ts videos, they wont open. I have to open up VLC player, then drag & drop the video file into VLC's window & then it plays fine.

To be clear, I am not using a VPN.

Here is my rclone version: rclone v1.61.1

  • os/version: debian bullseye/sid (64 bit)
  • os/kernel: 5.15.0-67-generic (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.19.4
  • go/linking: static
  • go/tags: none

I installed rclone & set up google drive with it in Zorin yesterday, it all installed & mounted fine & I followed my notes/instructions from my prior recent install for same thing in windows 7, very similar. I've read that its better & faster to use your own Google Drive client ID, so i did that too, I told rclone my client_id & my client_secret.

Zorin mounts my g drive, & I can explore it. But I can only see the file paths & file names. The video & picture thumbnails arent loading.
And I cant open any videos.

Issue #2: Also another issue i've been having with rclone on windows 7 & with Zorin OS Lite is that I cant search for something in the mounted drive like i could with Windows 7 when i mounted the drive using google drive.exe software, which worked the best by far, could quickly search my 200GB drive & find a folder or file. But with Rclone/windows & Rclone/Zorin its extremely slow at searching & is so slow I always abort it. It only finds like 5% of the files that match up with the search term when I let it run & is still loading/searching indefinitely, its so slow.

Please help. As google drive's web browser version sucks & i hate using it & it is very limited. I just want to mount & stream my google drive, I dont want to mirror it.

Also here is one article i found that may be of some use/help. It talks about how VPS (Oracle free tier) helped solve his throttling problem, I'm not even sure if throttling is my problem.

Lastly, maybe I should transition to a more linux friendly cloud service.

In Thunar preferences, you can increase the allotted size to show Thumbnails.

What is your set default for that mimetype?

1 Like

@Aravisian ,

Just to be clear, to help with context & to compare, I did not have as many problems with Windows 7, and google drive. The image & video thumbnails for Win 7 loaded excellent for the mounted drive & even for the seriously dying/slow speed, 7 year old SSHDrive. I'm not whining, again, I'm just using it as an example to compare.

In Thunar preferences, you can increase the allotted size to show Thumbnails.

All I can see in preferences is the "Show thumbnail: Always" option, is that what you're talking about? And even when I choose that, I still have problems with thumbnails. I'm using ZorinOS Lite.

What is your set default for that mimetype?

How do i check that? I'm not very familiar even with that term, even after googling I dont know how to answer your question.

I also should mention some other glitches or weird stuff too.
On my regular (non cloud) Zorin file system drive,anywhere in it, the picture & video thumbnails are acting weird & arent loading sometimes, a lot of them do load, but some dont. And it also depends on how large i have the thumbnails, the larger I make thumbnails, the more problems there are. Windows 7 never had this problem.

1.) Here are two examples of a non cloud photo thumbnail NOT loading properly even after I hit Ctrl+R to refresh the window. When i actually open it up, it loads fine though.


here is the file path for these photos, to help you understand.

2.)The thumbnails for non cloud videos dont load & glitch:

Here is the file path for this one: "/home/username123/Downloads/o_304995.mp4"

And also, Out of the box ZorinOS Lite could not play these mp4's with the Parole video player, which may be why i get this glitchy thumbnail, a codec issue? I had to drag & drop the video file into my web browser just to even play them, until i finally installed VLC player, which then worked awesome, but still, even after all that, the thumbnails still glitch currently like the above.

Also, currently when i double click a non cloud video file, it opens up in VLC player, no problem. But as I've said, when I double click a cloud video file, it wont open into the video player, it does nothing. No video player even opens. I have to drag & drop the cloud video into the VLC player to get it to play.

Here are examples of the issues with google drive:
1.) Photo thumbnails arent showing, no matter what thumbnail size i make them. Some thumbnails do load for the mounted google drive, but its an even worse rate than my file system non cloud photo thumbnails.

Here are examples of the file path for those above photos:

2.) The mounted google drive video thumbnails dont show, like they would in Windows 7. Windows 7 99% of the time worked flawlessly.

Here is the file path for this: /home/username123/Desktop/gdrive/Files/Word docx/Notes/Kurt Cobain murder notes/Documentaries/

-Thanks! :slight_smile:

I really think you are mixing up a lot of things here.
My Google (Suite) Drive 2 Tb, or One-Drive, just NEVER be connected with a software I know nothing or anything really about. So in the Security of your Cloud at Google you take a LOT for granted. That is what I see as a first mistake in the interpretion of Cloud -- Off-line data-disks.

My Gateway to Drive is Gnome itself, and of course Google Chrome (!!).
So when I need my Drive for anything Chrome -- Drive app built in, is the method for 100% safe warranties. And the ID + password remains in the Google Domains.
Gnome --- if offline and online data need to be modified or created in any way, my Gnome does NOT show Thumbnails at all on anything: logical the Safety of the Drive comes first. Gnome is just 'a Tool' for Google whereas "Windows " is a trusted OS for Google. Gnome can be anything from anywhere. So no in - out data allowded from Google !!!

At the other hand your Thumbnails are straight inside the Drive - service !!! So yes via Chrome-browser/ Drive-app you have a straight view on any Thumbnails you want and this on ALL kind of files.

Your methodism is deadly WRONG for implementing 'rclone' on a Secured Cloud Drive Space , and above all what warranties do you think you have ?

Google is number 1 Linux-friendly Cloud Service, but they will not allow cowboys and wild ideas on their Cloud infrastructure. So yup .... I like that very much even.

So install Chrome-browser from Google on Zorin, and learn to alter your methods on import and export from a Cloud in global ..... to give an idea PCloud will not even allow the violations you make with video's that have no clear ownership.
and for Google this is as well a part of the agreements that Clouds may not carry some protected ownership Video's or files, or cracking exe's etc .....
Nautilus of Gnome (online accounts - connection) syncs and load perfectly all files and folders in and out the Cloud (not Thumbnails allowded of course ! )

1 Like

These are a generic non-image icon.
Please remember that Windows and Linux are different operating systems. That one works differently does not mean that one works and one doesn't.
The cause of this may be that in settings; it is set to only show a thumbnail when a file is a certain size or if they are saved locally. Please launch the File Manager and navigate to Edit > Preferences and then see this image from my computer:

You see under Display that Show Thumbnails and it is set by default to Local Files Only. Change this to Always. (You mentioned this above).
Reboot and test if thumbnails are showing thumbnails instead of the icon you posted an example of.

You said above that some are still not showing correctly- if I assume for a moment that changing that setting does affect whether it shows thumbnails for all, not just locally - and that is working properly - we are left with this:

This is not a generic icon. That looks like a broken image.

None of the above sounds normal, to me. I use Zorin OS Lite exclusively and I have never experienced this behavior, either.
I think you are on the right track about codecs; but I suspect something may still be broken even after adding them - that this is more than one issue.

Since this is a new or maybe even fresh install helps, though. If this was me; I would save myself a lot of headaches by reinstalling Zorin OS.
This might be a corrupted file that occurred during the download process or the read/write process when installing from the LiveUSB.
Download your copy of Zorin OS 16.2 Lite fresh. This is to avoid the potential that the previous copy had a mismatched file during the download.
Write the Bootable Copy Fresh on a USB Stick - this is to avoid a problem created during the write cycle previously. I recommend using Unetbootin, Ventoy or Multiboot Not BalenaEtcher.
Completely wipe the partition Zorin OS is on - then reinstall the fresh copy.

Once this is done, we can then do some things to help ensure that Codecs and the like are not going to be an issue.
With Windows; some things are proprietary. On Linux, this is disallowed to be included as default but we can still install them legally afterward.
So let's install those.
I still recommend you do a fresh install from above - do not skip those steps and go straight to here because I think it is clear that there is a standing issue above that this will not resolve.
Once the fresh install is complete and you have restarted, please install the extra codecs and fonts:

Update all sources:

sudo apt update

Install codecs extra:

sudo apt install ubuntu-restricted-extras

Install Microsoft fonts:

sudo apt install ttf-mscorefonts-installer

EDIT: ahhh... see, I was trying to address too many things at once and I forgot one more line to run:

sudo apt dist-upgrade

1 Like

@joshuaorbit , thank you for your response. Could you please review/re-read your last comment, as I'm having a hard time understanding it. I think english is not your first language?

I think one issue you are pointing out, is why am I storing 200GB's of data with google drive but not encrypting it? why am I allowing google drive to see all my data? That is an excellent point.
I dont like this either, & have been planning for a while to encrypt everything.

What method would you recommend where I can client side encrypt everything that I put on the cloud, but also all thumbnails load properly when I do decrypt it on the cloud & explore my drive?

Is Cryptomator a good idea? what about client side encrypts everything & I heard they are not proprietary.

@Aravisian , I got "Zorin-OS-16.2-Core-64-bit-r1" downloaded, I will make a bootable USB stick, but once I do, how do I encrypt ZorinOS during install? and what options do i have in encrypting it? I want to choose the best encryption, most secure. I also got UNetbootin installed also.

In the Ubiquity installer, you will see an option to encrypt during install.
Here is a guide for Ubuntu which is nearly the exact same:

LUKS full disk encryption is extremely secure which the reason we usually advise against it. It is so secure that if you lose your passkey, your data is gone.
Even a reputable good data recovery company will turn you aside.

1 Like

@Aravisian , Thanks! I'm working on it now. And:

"LUKS full disk encryption is extremely secure which the reason we usually advise against it. It is so secure that if you lose your passkey, your data is gone.
Even a reputable good data recovery company will turn you aside."

Thats actually exactly what i want to hear :smiley:
I'm actually interested in creating hidden volumes/OS's inside a volume & also use a LUKS equivalent to a personal iterations multiplier, which I've been told that "--pbkdf-force-iterations" parameter & "--iter-time" can do this & some other related params. But i know nothing about this & would need a walkthrough. If you dont want to do this, I totally understand. :slight_smile:

I do not. And for a good reason: I do not understand it well enough to trust myself to do a good job.
Which given the above statement that you wanted to hear, we can see the wisdom in that.
I do not really mess with encryption very often - so I am novice on the topic, at best.

1 Like

@Aravisian , I downloaded "Zorin-OS-16.2-Core-64-bit-r1,3-5-23.iso".
I then reformatted the jump drive to Ext4. I then used UNetbootin & installed the iso to that USB drive. I then restarted the computer & booted to that USB drive. Here is the errors I got,see two screenshots, I am typing this while booted from the new Zorin boot OS that has errors.

What should i do now? I am in a tough situation right now personally, & really need to get this Zorin working. My Windows 7 SSHD is failing & crashes, etc.

I still have the ZorinOS Lite installed on my SSD thankfully, I will return to that one in the mean time.

Were you dual booting alongside of Windows? If so, you must ensure that Windows "Fast Startup" or "Fast boot" was disabled in the Windows Control Panel > Power settings.
Fast Boot locks the drive, preventing write access.

I've never dual booted with windows. My Windows 7 was on a 1TB SSHD that is 9 years old & is seriously failing. And my ZorinOS Lite that I'm currently using & typing with is on a brand new samsung SSD that i've never used for anything before. I created a 94GB Ext4 partition for it to install the ZorinOS Lite.

The remaining 418GB is not partitioned at all.
I cant remember if during the install of this ZorinOS Lite SSD partition using a USB drive, if i got errors with it or not, I might have. It didnt allow me to screenshot, so if i did get errors it was not easy to remember/record.

But I definitely got errors, as you can see when I tried to boot from the newly made USB drive that has the ZorinOS Core iso.

Please help.

The image previews that you are used to are configured through the file browser (Files a.k.a Nautilus). In that application, you can set what is available through the preferences:

Thumbnails are defaulted to only files on the computer that are under 10MB (may be different on your machine. It also will not by default allow remote directories (even shared on your network) to show thumbnails.

In google drive, you will have to work on those settings (I believe it defaults to images less than 2MB). If you have the Google Drive Gnome Tweak, it should follow your file browser's settings.

1 Like

@337harvey , Thanks! How do I get "google drive gnome tweak"?

You can Google it? I think there is a tutorial in the guides category... again, the search would be more helpful. I remember it mentioned, don't remember where.

@337harvey , thank you for your suggestion. I tried this already actually. Problem was is that I couldnt find "GNOME Online Account" to sync to my google cloud. I think it's only available on ZorinOS Core? not ZorinOS Lite? i dont know. Perhaps @Aravisian can comment on this too.

I cannot be very helpful. I avoid Google Drive as much as I do Gnome. Alternatives to Google Drive are Sync cloud, pcloud,
For many cloud storage services, you must pay to get meaningful storage space.
If you need large amounts of data safely stored - it is well worth the fees with most reputable places.

You can install on Zorin OS Lite:

sudo apt install gnome-control-center gnome-online-accounts

Gnome Tweak Tool is for Gnome only. You will need to set XDG Desktop to see as Gnome for the Gnome Control Center

XDG_CURRENT_DESKTOP=GNOME gnome-control-center

Launch Gnome Control Center and in the left pane, scroll down to Online Accounts

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.