Issues with saving multiple attachments in Evolution email client

Hello,

I am reaching out to report a couple of issues I've encountered with the Evolution email client on Zorin OS 17.1. I appreciate any guidance or support on these matters.

1. Inability to batch save multiple attachments:

When attempting to save multiple attachments from an email, the "Save all" functionality does not work as expected. Whether using the "Save all" button next to the attachments or selecting more than one attachment manually, the process fails. The following error message is displayed:

Could not open /run/[filepath]/[attachment.name]
Permission denied

image

The actual save location selected was: ~/Documents/protokol 50/

The folder mentioned in the error can be accessed by the same user (me) and has appropriate permissions. The two files in the folder in the screenshot were saved one by one.

This issue prevents the batch saving of attachments, necessitating a workaround or individual file saving, which is less efficient.

2. Save dialogue box does not remember last saved location:

Moreover, when saving attachment items one by one, the save dialogue box fails to remember the previously used save location. This lack of memory results in a tedious and cumbersome process, as I need to navigate to the desired save location for each individual attachment.

Ideally, the save dialogue should remember the last location where items were saved, streamlining the process for users handling multiple attachments.

Attempted troubleshooting steps:

  • Checked for updates to the Evolution email client and the operating system to ensure I am on the latest versions, Zorin 17.1, Evolution 3.52.0 (by Flathub.org)
  • Reviewed permissions for the /run/ directory to identify any potential misconfigurations.
  • Searched the forum and online resources for similar issues and potential fixes, without success.

I am currently running Zorin OS 17.1, and the issues have been not present in Zorin 16 before the upgrade. I would greatly appreciate any insights, solutions, or workarounds the community or development team might have.

Thank you for your attention to these matters.

This may be the issue. Packages installed through Flathub (known as flatpaks) have restricted permissions by default so that they cannot access the filesystem freely. If going with the preinstalled version of Evolution is not an option (which would mean downgrading to 3.4.4), then I suggest you install Flatseal from the Software Store and give the necessary permissions to Evolution:

Add a new entry as shown; xdg-run is short for /run/user/<user_id> which should grant permission to that whole directory and everything underneath it.
If this doesn't work you may need to grant permissions to ~Documents/protokol 50 as well.

Thank you! It was enough to allow All user files in Flatseal and the batch save worked:

2 Likes