Issues with Zorin not recognizing Macbook bluetooth adapter

I recently l loaded Linux on my Macbook 2015. It runs pretty smoothly on this machine, but there is one major issue. Bluetooth doesn't work. I installed Blueman already, but opening the App does not do anything to the machine. Any help is appreciated here.

Can you please post the output of

dmesg | grep -i blue

Ensure bluez is installed

sudo apt install --reinstall bluez

re-installed bluez, nothing.

$ dmesg | grep -i blue
[ 5.810722] Bluetooth: Core ver 2.22
[ 5.814416] NET: Registered PF_BLUETOOTH protocol family
[ 5.814420] Bluetooth: HCI device and connection manager initialized
[ 5.814425] Bluetooth: HCI socket layer initialized
[ 5.814429] Bluetooth: L2CAP socket layer initialized
[ 5.814436] Bluetooth: SCO socket layer initialized
[ 6.002969] Bluetooth: HCI UART driver ver 2.3
[ 6.002976] Bluetooth: HCI UART protocol H4 registered
[ 6.002979] Bluetooth: HCI UART protocol BCSP registered
[ 6.012061] Bluetooth: HCI UART protocol LL registered
[ 6.012067] Bluetooth: HCI UART protocol ATH3K registered
[ 6.012087] Bluetooth: HCI UART protocol Three-wire (H5) registered
[ 6.012123] Bluetooth: HCI UART protocol Intel registered
[ 6.012180] Bluetooth: HCI UART protocol Broadcom registered
[ 6.012195] Bluetooth: HCI UART protocol QCA registered
[ 6.012197] Bluetooth: HCI UART protocol AG6XX registered
[ 6.012212] Bluetooth: HCI UART protocol Marvell registered
[ 39.677236] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 39.677242] Bluetooth: BNEP filters: protocol multicast
[ 39.677249] Bluetooth: BNEP socket layer initialized

1 Like

Run each separately as a new line in terminal:

sudo systemctl enable bluetooth.service

sudo systemctl start bluetooth.service

no fix quite yet sadly. The bluetooth switch toggle in settings is greyed out with the following message displayed: "no bluetooth found, plug in a dongle to use"

Terminal output for


and also

sudo lshw -C network

Bus 002 Device 001: ID ***** Linux Foundation 3.0 root hub

description: Wireless interface
product: BCM4350 802.11ac Wireless Network Adapter
vendor: Broadcom Inc. and subsidiaries
physical id: 0
bus info: pci@0000:01:00.0
logical name: wlp1s0
version: 05
serial: a8:66:7f:1e:15:cb
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=brcmfmac driverversion= firmware=01-c45b39d6 ip=
***** latency=0 multicast=yes wireless=IEEE 802.11
resources: irq:52 memory:c1400000-c1407fff memory:c1000000-c13fffff

It looks like this driver is needed:

Installation instructions:

git clone

cd macbook12-bluetooth-driver/

sudo ./

Driver installed, but still no luck here

Go ahead and try these, now:

sudo systemctl enable bluetooth.service

sudo systemctl start bluetooth.service

Done, no change quite yet


I will try searching them thar interwebs...

I'm surprised because I know this one is from the era when Apple worked with Intel for standard-ish hardware. I thought for sure it would be plug-and-play.

I appreciate all the effort you are going through to help me with this.

This may seem silly, but try:

sudo rmmod btusb

sudo modprobe btusb

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.