Java and Prorealtime

Hello guys,

I am a newbie on Linux and i like how it's work.
I installed Zorin OS on A Vmware to test it. i'm loving it and i want to install it in a double boot on my PC.
the only problem to finally switch to Zorin OS is that i am not able to launch Prorealtime (a stock software based on java). i followed a tutorial to install java. I tried on Ubuntu and that's work but the same tutorial does not worked on Zorin. It's a pity because i'd would like to use Zorin OS instead of W10. Java is obviouly operational once the installation made but ProRealTime doesn't start.
Is someone can tell me the way to make ProRealTime functionnal on Zorin OS?
Thanks a lot.

1 Like

I don't know that app but try launch the app via the terminal, it might tell what's going on.

1 Like

Hello, thanks for replying.
it's an app thats launched by an webpage link. you have to log in on a website. you click a link which require java to lauch the app.
I installed Zorin in a partition of my second SSD to have all the power of the PC and not just a vmware version.
Sometimes, ProRealtime works after 2 minutes of loading and 95% of time, it doesn't work. i have sometimes an error with a "java and internet problem". I have none firewell nor antivirus...
on Windows the app works after 10 seconds of loading.
I'm frustrated because i want to understand why it doesn't work.
You adviced me to launch the app with the terminal but i can't because of the particular way of launching ( via the web link)

What does running

java -version

in terminal yield?

here what i get :
openjdk version "11.0.13" 2021-10-19
OpenJDK Runtime Environment (build 11.0.13+8-Ubuntu-0ubuntu1.20.04)
OpenJDK 64-Bit Server VM (build 11.0.13+8-Ubuntu-0ubuntu1.20.04, mixed mode, sharing)

Perhaps the tips here may help.

Thanks for your message. it's helped me.
Now, PRT is launched as quickly as W10! i spend my first day with linux/Zorin OS.

i forgot what i did exactly to install java but what it's sure that java 8 is necessary for PRT, not java 11.
java -version in cmd :
openjdk version "1.8.0_312"
OpenJDK Runtime Environment (build 1.8.0_312-8u312-b07-0ubuntu1~20.04-b07)
OpenJDK 64-Bit Server VM (build 25.312-b07, mixed mode)

1 Like