Keeping Brave set as Default Browser? [SOLVED]

I am using Zorin 16 Pro and had problems with Brave and removed and replaced it using the Software program. Now every time I open it, it keeps asking if I want to make it the default so I say yes and set it as default, every time I open Brave it keeps asking to set as default. I have used the Terminal to remove it and using the software program. I removed Opera, Firefox, and it still keeps asking.
I went in setting and set it as the default application and in the Setting in Brave but when I click on make it default in Brave it doesn't seem to change it. I have searched but did not find anyone with this problem. I think the old install is making it mess up but I don't know the code to remove as it just removes the newest version. Any ideas? Thanks. :+1: :+1:
I noticed that on another computer with Ubuntu 22.4.1 LTS I am having the same problem so I would say that it is in Brave somewhere.

What Source did Software install Brave from?

I am not sure what it is called but it is the Software program that came with Zorin 16 Pro. I go into System Tools and there it is, the little brief case. It is Software 3.36.1
I have the same happening in Ubuntu 22 also so I would say that it might be a Brave bug that is the problem.

Please launch the Software store app and then your Installed tab. Look up Brave browser
When you see the entry, select it.

In Zorin OS, the ZorinGroup added a Source button on the titlebar. You can check there to see which source you installed from.
You can also scroll down on the installed Brave page in Software to see the source listed at the very bottom.
I am guessing Flatpak is the source in this case. Could be Snap.

Brave has the source as
Brave version is 1.46.133

The developer is the Gnome Project.
The source it has as "lp_ppa_zorinos_patches-focal-main"
It has Flatpak and Snap support.

Ok, so you have Brave and its install source is Snap.

You can remove it (Either from Software Store or from terminal with snap remove brave-browser) - then check your Home Directory for /.config directory. If you see none of the hidden files, tap ctrl+h to reveal them.

In ~/.config, check for a Brave Browser folder. If there is one, remove it.

Once done,
Let's try an APT version of Brave. Since they do not keep a repository in the vein of other apps, you will need to set some things up, first.
Please open a terminal and run this command (copy it and paste it in your terminal) to add the repository signature / key.

curl -s | sudo apt-key --keyring /etc/apt/trusted.gpg.d/brave-browser-release.gpg add -`

Next, run this command to add Brave to your apt sources:

echo "deb [arch=amd64] stable main" | sudo tee /etc/apt/sources.list.d/brave-browser-release.list`

Now, run this to update the sources and install Brave Browser:

sudo apt update && apt install brave-browser

Once installed, launch Brave and configure your personal settings.

Then, reboot and test.

I'll get to all that tomorrow. But it is doing it on two computers. After I do all that I'll post here. Thanks.

1 Like

I tried what you said, maybe I was doing it wrong but all I got was Conflicting command and command not found, so what I did was delete Brave, restarted the computer and then in Terminal I used...

sudo apt install apt-transport-https curl

sudo curl -fsSLo /usr/share/keyrings/brave-browser-archive-keyring.gpg

echo "deb [signed-by=/usr/share/keyrings/brave-browser-archive-keyring.gpg arch=amd64] stable main"|sudo tee /etc/apt/sources.list.d/brave-browser-release.list

sudo apt update

sudo apt install brave-browser

Now everything is working as it should and Brave is the default browser. I don't understand most of it and probably never will but..
Thank you for all the time and help in getting this corrected, hopefully this might help others.

If, as the title now says, this is now solved, can you mark the post that gave the solution - even if it was your last post.
Just click the three dots underneath the post to reveal the toolbar showing :ballot_box_with_check: Solution and click it. Thanks, Zab.


You are 100% capable of understanding it.

There are three sources for installing packages common in Linux now. This is something kind of New. Because Flatpak and Snap are kind of new.
In brief; Flatpak and Snap are alternatives to the standard APT package management.
Both of these new sources carry all dependencies needed to run the application with them and are containerized. Containerized means that they are isolated from the rest of your system so that they use the dependencies they brought, instead of the ones you already have installed on your system.
But containerizing them also means they can be cut off from needed system files anyway - such as personal configurations (Or system themes or other configurations).
A Container is fine if you want to test something without blowing up your computer. But for running a daily-use app on your daily-use machine, it is troublesome and problematic.

What you did was you removed all of that including the contained application data.
Then you installed from One Source that is not containerized.
Now, the browser is able to see and use all the necessary system files on your machine.


I had the same problem on another install and after reading, it is a problem with Snap. If this is the case then I'll get rid of Zorin. I want to use Brave but don't want the problems, I can't set it as the default browser. Unless the makers of Zorin has a solution.
The fix that worked last time won't work this time. So it is not solved.

I do not understand what you are saying here...
Is your message that if you cannot get the Snap Package to work, you would prefer to use a different OS>
Or that you do not care if it is the Snap or the Standard .deb package, you just want it to work?

Because the standard .deb package absolutely will work.

The Snap install works great but something is missing and it will not set Brave as the default browser, it keeps asking, and if I click set as default it won't stay the default, then when I go into braves setting it is not the default browser.
I just had this problem on my other drive and what I posted as the solution won't work this time for some reason.
I want Brave as my default browser and the one for snap has a bug in it.
I don't care what it is, Snap or the Standard as long as I can get it setup and running.
The solution won't work for some reason? The other post on Zorin that I was reading they had problems installing and they never did get a solution and it had something to do with Snap. Thanks for the reply.

In that case, I would suggest removing the snap version entirely.
I think it is

snap remove brave-browser

Then install Brave Browser with the .deb
In terminal copy and paste each of these;

curl -s | sudo apt-key --keyring /etc/apt/trusted.gpg.d/brave-browser-release.gpg add -
echo “deb [arch=amd64] stable main” | sudo tee /etc/apt/sources.list.d/brave-browser-release.list

sudo apt update && sudo apt install -y brave-browser

I went to Installing Brave on Linux | Brave Browser and tried the first setup line by line, then copying all at once, then line by line again, I did it four time and the fifth time I tried it then it installed. I set it as the default browser and it stayed the default.
I did have to remove the snap version again. I'll do it all again to see if it did take care of the problem using a different solution.
Thanks for the reply.

You may need to check etc/apt/sources.list.d and ensure you do not have multiple repository entries, now.

1 Like

That took care of all the problems. Thanks for the advice.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.