Kernel panic during installation of Zorin Core OS

It's been awhile since I post here. Hope everyone have a merry christmas and a happy new year. Anyway, this problem isn't mine, but I want to help a friend. He's experiencing Kernel panic during installation of Zorin OS Core. He tried using Rufus, Balena, and WoeUSB to create the bootable installer and still experiencing the same problem. Lenovo Ideapad Slim is his laptop. And this might add on how to solve the problem: he is also experiencing problem installing Windows, but it does crash or can't see the eMMC. He also tried disabling secure boot but didn't work. Any clue what he needs to do or the cause of the problem?

specs: Lenovo IdeaPad Slim 1-14AST-05 81VS - A6 9220e / 1.6 GHz - 4 GB RAM - 128 GB SSD NVMe - 14" TN 1366 x 768 (HD) - Radeon R4 - Wi-Fi 5, Bluetooth - ice blue

Basically your system can not boot as the root file system can not be mounted. Could be anything from a bad hard drive to having changed the uuid of the root partition. You need to boot a live usb and investigate.

I sent to my friend your reply. Will message if anything changes. Thanks!

format the NVMe with the NVMe-format standard (not ext 4 and not ntfs or other file systems).
Check the UEFI, Bios for secure boot setting (must be set OFF) , and the FAST boot option (turned OFF) . These 2 can spoil the party as well for installing anything.
For NVMe formatting click on this link.

1 Like

There have been problems reported in the past re installing and emmc drives, so maybe worth searching the forum.
Maybe have a read of this thread, although I have pointed to one particular post within it: Installer not picking up main drive - #30 by Aravisian

1 Like

he said gparted can't see the drive so maybe this link can help in some way thanks.

Which are you attempting to install to, NVMe or eMMC? This makes a huge difference in how the bios is setup. NVMe works if the ssd type is set to AHCI in the bios, eMMC does not consult this setting as NVMe does.

like I said, this isn't my issue but my friends. I'll just pass your question to him though and thanks

He uses emmc. He said he manage to install it to another laptop using emmc too, same spec in ram, etc except that the emmc of that laptop have bigger size than this one.

Size is likely to be the issue. Also if it came with Windows originally eMMC boards are hardcoded to Windows, the newest ones that is. Your friend would be better off selling both and purchase a second hand old Notebook that can be upgraded as you can't do that on new machines.

I doubt he will sell it for that reason though. hehe anyway thanks for the help. How should I put it, if he wants he will create his own OS just for this one.