Kernel Panic when booting up Zorin 16 desktop

Hey, guys my dad's computer - that has been running Zorin 16.2 Core for a while now, and before that Z15 for close to a year - just started spitting out this when booting up.

https://imgur.com/a/AJd4jRB

What could be causing this? My dad is able to boot into live environments from USB sticks and all 32 GB of RAM are detected. What could be causing this?

Haven't gotten to visit him and try to take a look at it myself yet, but he says he hasn't touched the hardware, tried to install another OS, or anything as such.

Try run RAM check. It could be that one of the RAM stick has kicked the bucket or is about to do it.

EDIT: Some net research indicate it could be a HHD/SSD fault.

What tests/commands would you recommend I run when I get there later today?

IF you run a live DVD/USB of Zorin you can memtest86+ it. Note it takes some time to run it completely.

More of the subject: https://www.memtest.org/

Thank you, I will when I get a chance.

Note: you may hit tab or esc to get to GRUB menu in Zorin.

Okay, I ran it and the memories passed.

https://imgur.com/a/X48Eth9

The only thing that caught my eye is that the RAM may be running at 1333 MHz instead of 2666 MHz. Is that what the box on the left is saying? And could that be causing this issue?

Are your two RAM stick identical?
Do also check BIOS if the RAM is set to 2666 MHz

Another option is to upgrading BIOS if you haven't recently.

Back to the problem:
run the live USB/DVD and test the HDD/SSD by

gksudo gnome-disks

and run tests

Yes, they are identical.

And I will check the bios for the frequency. Plus I am sure it can be updated as it is a gaming one I believe. I am sure it was never updated, as my dad has no clue how to do it. The only reason he got that one is bc he needed one in a hurry and during the pandemic shortage, that is what was available.

Thank you, I will update here after I run that test.

Bios says they are running at 2400 MHz

Try sudo instead of gksudo.

sudo gnome-disks

It may be a dynamic clock speed for the ram. This is normal anymore and not the cause of your issue.

As was recommended, checking the disks would be the next step in troubleshooting. Bad sectors/blocks can cause read errors. If this comes back with issues, pay attention to how many sectors/blocks were marked. Two or three shouldn't be anything to worry about. More than that could indicate drive failure and should be a warning to look into getting new drives, before it's too late to recover data.

I was unable to test the SSD:

Only the HDD:

Is it normal that the SSD wasn't able to be tested by gnome-disks?

Not all disks are supported for smart tests. You can open disks and run a check to see if there are any invalid sectors/blocks.

I ran it for the HDD, the image is the result. Should I have run another one instead?

And what test should I run for the SSD?

And an update on the problem: it is an intermittent thing. My dad was able to turn on the computer and it worked perfectly fine, then sometimes when powering it on the issue happens again. He has been keeping it on for now.