Keyboard backlight modes not changing on Toshiba portege

Im trying to change my Tosihba portege x30-d backlight modes by fn + z keys
It has 3 modes:

  • on
  • turn on by pressing any key (15 sec)
  • off
    It was working on windows but in zorin when I pressing fn + z the backlight icon appears on screen but nothing happens
    Note: it's on default bios mode (15 sec on) now

Manufacturers built with Windows in mind, not Linux.

Have you tried OpenRGB?

It cant find any device in device list

For my gigabyte stuff I have to add


To my kernel boot parameters in grub for open rgb to work. Maybe try that for one boot cycle if it works make it permanent

1 Like

Aw, geez... when I was researching remapping the hard drive light to the Mute button LED or the CAPslock key LED, I also came across how to remap keys to change the keyboard backlight ... but I don't have a keyboard backlight, so I read it, but I didn't bookmark it... let me see if I can find it again.

I'm not sure if this is it, but try this:

Zorin menu > Settings > Keyboard shortcuts
Scroll to the bottom and click the '+' button.

Enter the following:

Name: Keyboard Backlight On
sh -c 'xset led 3'

If that doesn't work, try:
gnome-terminal -- /bin/sh -c 'xset led 3 '

Shortcut: Fn+Z (or whichever key comination you want)

Name: Keyboard Backlight Off
sh -c 'xset -led 3'

If that doesn't work, try:
gnome-terminal -- /bin/sh -c 'xset -led 3'

Shortcut: Alt+Z (or whichever key combination you want)

This might give you some tips if your keyboard backlight isn't LED 3:

You can, if you want to get crazy about it, remap your hard drive LED to the keyboard backlight LED. LOL


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.