Keyboard not working on Laptop Cepter N530-04

I bought a laptop Cepter N530-04 and it was set up with Windows 11. I am no fan of windows, and I want Zorin OS on it like I have it on my old Laptop and my main computer.
But - When I start the Zorin install process, it doesn't recognize the keyboard. Mousepad is ok. FN + F7 to turn off the LCD screen also, but no input from letters.
I plugged a usb-keyboard and that runs.
I set up my laptop, but after install still no active keyboard. Mousepad ok.
I don't want to run my laptop with an external keyboard of course, so does anyone have a solution to my problem?
I have tried deinstall and install again "sudo apt install xserver-xorg-input-all". No keys function.
I tried install ubuntu - same.
I tried install manjaro - same

Welcome to the Forum!

Did the Keyboard worked with the installed Windows 11?

Yes it did, no errors

I first tried to install alongside Windows11, and when I used windows11 the keyboard was fine, but as I then went over in Zorin.. no function

Hmm ... Sounds for me a bit that it isn't supported ... Did You tried it with X11 and Wayland?

Do you still have Windows installed?
If you do, Turn off Fast Start in Windows before you ditch it, at
Control Panel>Power Options>What the Start Button Does.

Also in BIOS, Disable Secure Boot, Disable Fast Boot.

1 Like

After trying around with windows installed as dual boot, I deleted the disk and installed Zorin alone at my laptop. I did not turn off fast start before I threw it away, but I have disabled Secure Boot and TPM in Bios. I do not seem to be able to disable fast boot in bios, not found it at least...

when I am in Bios, I move around using my keyboard, there it works. Could it be some kind of windows catch in the keys, that is holding it back? I read that one should not take notice of those numbers when secure boot is disabled, so I do not trust to try it out....

Touchpad and mouse function is running fine on the laptop, and right now I am writing on the machine with an usb keyboard...