Keyboard not working while installing

After clicking on try or install zorin (safe graphics), I landed on zorin desktop where i clicked install zorin and since then the keyboard is not working. I was unable to type location, etc. Right now, i am on this page and not able to tyoe anything.

Did you try the Live USB first to see if things worked before you went for the full install? You can also just try to plug another keyboard if you have one available, or see if there's some indication of a "on-screen keyboard" meant for accessibility. I'm not sure if this would show up at this stage but is worth a try.

That worked for now. But after installation, the on board keyboard still doesnt work and the wifi option is also not showing in the settings page. So i cant update drivers either. I cant reinstall xserver-xorg-input-all.
What do i do?

Run this command and share output-

lshw -C network

try connecting wired connection/ethernet. then run

sudo apt full-upgrade

If keyboard still doesnt work, run

sudo apt remove xserver-xorg-input-all
sudo apt install xserver-xorg-input-all

Still not working

Unclaimed network huh.
Maybe try this?

(Zorin 16 is based on Ubuntu 20.04)

Not working.
I think there was some error while installation(i was very confused while selecting partition part of installation). How to check if there are more errors caused. i am new to linux but i think these information might help find the root of the problem.

Keyboard and wifi works inside bios menu.

lshw -c network
WARNING: you should run this program as super-user.
  *-network UNCLAIMED       
       description: Network controller
       product: MEDIATEK Corp.
       vendor: MEDIATEK Corp.
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list
       configuration: latency=0
       resources: iomemory:600-5ff memory:6000000000-60000fffff memory:80900000-80907fff
       description: Ethernet interface
       physical id: 1
       bus info: usb@1:1
       logical name: usb0
       serial: d2:6d:51:fa:7c:e3
       capabilities: ethernet physical
       configuration: autonegotiation=off broadcast=yes driver=rndis_host driverversion=5.15.0-73-generic duplex=half firmware=RNDIS device ip= link=yes multicast=yes port=twisted pair
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

00:00.0 Host bridge: Intel Corporation Device 4617
00:02.0 VGA compatible controller: Intel Corporation Device 46d0
00:04.0 Signal processing controller: Intel Corporation Device 461d
00:08.0 System peripheral: Intel Corporation Device 467e
00:0a.0 Signal processing controller: Intel Corporation Device 467d (rev 01)
00:12.0 Serial controller: Intel Corporation Device 54fc
00:12.6 Serial bus controller [0c80]: Intel Corporation Device 54fb
00:14.0 USB controller: Intel Corporation Device 54ed
00:14.2 RAM memory: Intel Corporation Device 54ef
00:15.0 Serial bus controller [0c80]: Intel Corporation Device 54e8
00:16.0 Communication controller: Intel Corporation Device 54e0
00:19.0 Serial bus controller [0c80]: Intel Corporation Device 54c5
00:1c.0 PCI bridge: Intel Corporation Device 54bb
00:1d.0 PCI bridge: Intel Corporation Device 54b0
00:1f.0 ISA bridge: Intel Corporation Device 5481
00:1f.3 Multimedia audio controller: Intel Corporation Device 54c8
00:1f.4 SMBus: Intel Corporation Device 54a3
00:1f.5 Serial bus controller [0c80]: Intel Corporation Device 54a4
01:00.0 Network controller: MEDIATEK Corp. Device 7902
02:00.0 Non-Volatile memory controller: Intel Corporation Device f1aa (rev 03)
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 13d3:3579 IMC Networks Wireless_Device
Bus 001 Device 004: ID 046d:c534 Logitech, Inc. Unifying Receiver
Bus 001 Device 003: ID 13d3:54a1 IMC Networks USB2.0 HD UVC WebCam
Bus 001 Device 007: ID 2717:ff88 Xiaomi Inc. Mi/Redmi series (RNDIS + ADB)
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
uname -r

1 Like

I think you might want to try the Live USB first. That is, when you plug the USB with the ZorinOS iso, selec the "Try ZorinOS" option instead of installing. This will boot to ZorinOS directly running from within the USB and you can test if things work out there. If you don't have any issues then it's likely a faulty install and you can just try that again.

Also, I notice that ethernet is working with a driver - do you have an ethernet cable in case further troubleshooting is needed with the Wifi Driver?

But i have already installed it and removed windows.

I have connected my phone via usb cable and turned on usb internet tethering which is working well but i want to fix my wireless wifi problem and the keyboard problem.
Please help me. I have no idea what is going on.

Can you please list the Notebook Make and Model?

ASUS Vivobook Go 15 (E1504GA)

Searching that yielded:

This leads to:


I am sorry but I cant understand solutions they're talking about. I am new to linux.
Can you summarize the steps of solution or make it understandable for a newbie like me.

This is a very unusual situation that even a ten-year veteran of Linux would balk at.

There are steps outlined to install with the later kernel... But since you have already installed Zorin OS, we may be able to skip that bit.
Do you have means of connecting to the net (ethernet or hotspot)?
We should see if we can get your hardware working first and once your keyboard is working, then try getting your wifi working.

1 Like

yes, i have internet access.

Add this repository:

sudo add-apt-repository ppa:tuxinvader/lts-mainline

sudo apt update

sudo apt install linux-generic-6.2

Once the kernel is installed, you must reboot to boot into the later kernel.
Once you reach the desktop, open terminal and run

uname -a

to check that you are on the 6.2 kernel and not the 5.15 kernel.

And don't forget to turn off secure boot if you haven't as these are unsigned.

And I just do

uname -r

-it's a shorter version of -a.

1 Like