Keyring won't unlock

Hi.

I have been using Zorin for months now and had no serious issues until now. Until yesterday I always login to my system with howdy and then I will enter the password to unlock my keyring. Except now I don't get a password prompt for the keyring. I tried to manually unlock it from seahorse and it just does nothing when I click unlock. So I restarted, covered the camera and logged in with the password but the same problem. To get my pc working again I had to change the password on the keyring to blank to decrypt it. Now it works but I would like to put encryption back onto my keyring without it breaking. Anyone had this issue?

Are you using a Chrome-based Browser?

This is a known issue with Howdy, however, I must point out that it is as much an issue with Chrome-Browsers. The only reason I can point some of this toward Howdy at all - is that some other apps besides Chrome Browsers can cause this issue. If not for that, I would place it squarely on Chrome.
Because Chrome Browsers can have this issue, when not using Howdy. The best bet is to use workarounds for Chrome Browser, rather than try to address Howdy's side of it.... IF you are using a Chrome-based browser.

I have vivaldi but all this software has been working fine together. The only thing I did yesterday was do the software updates and setup evolution. I can login with my normal password and go straight to seahorse without opening anything and it still won't unlock. That's why I had to remove the password completely which, as I said, is not a long term solution :slight_smile:

I will speak quite plainly...
I love Vivaldi.
But I will not install or use it. Vivaldi is the most unstable browser I have ever used. By far.
I am utterly unsurprised to hear that it was working fine one moment, then not the next.
If sticking with Vivaldi, the best bet is the usual Chrome Workarounds for Keyring:

you seem to be missing the point that it's not an issue with my browser unlocking the ring. I can't unlock it with anything. No remmina, seahorse, evolution. None of them will unlock it. Remmina and evolution open and ask me for my passwords instead of fetching from the ring. Vivaldi doesn't open because it needs the password to unlock sync. None ask me for my keyring password to even attempt an unlock. When I go to seahorse I can my login keyring and open that. But my default keyring, when encrypted, refuses to open. I click unlock and it just does nothing but grey the button out. I close seahorse and open it again, same as before. Click unlock and it does nothing. Change password in seahorse works luckily which is how I decrypted it

Do you have any other encryption on the system?
Did you encrypt the drive during Zorin OS Install?

In the meantime, you might try:

sudo apt install --reinstall ca-certificates policykit-1-gnome

What you describe almost sounds like a GPG failure- but that is Very Rare...

I did encrypt it when I installed it however reinstalling those 2 packages seemed to fix the problem. Thanks a lot

You're not running i3 at all?

It's fixed now but no I don't have i3 unless zorin put it there :slight_smile: I put zorin on the laptop I use for work so I keep it close to stock because it's meant to be stable and just work. A perfect fit for Zorin I think unlike my gaming pc which runs EndeavourOS. Steam needs those latest packages

It went back to broken again and the reinstall didn't work. I guess I will just rely on the drive encryption.

Do you have auto-login enabled?

I realize that asking this may seem counter-intuitive since you are also using Howdy... But I need to ask it all the same.

Have you also asked about this with the Howdy development team? I already know that they are aware of these types of issues...

Your keyring is located in your home directory:
~/.local/share/keyrings/login.keyring
In some cases, if you reset your password, then immediately remove that login.keyring file, then the newly created one on reboot should resolve the issue. However, since you are using Howdy, I am hesitant to suggest any file removals given that you have several different encryption and authentication techniques all going at once, here.

I deleted the login keyring and then changed my password to make a new one then put the password back on the default ring. Now the default ring unlocks like it should which I don't fully understand but I'll see if it stays fixed :slight_smile:

1 Like

Being fearless.
If it works, I am glad you took the chance on it after-all.

I did but alas it didn't work. I have confirmed it to be a howdy issue but it seems to be combined with evolution to make this weird issue. Evolution goes to the keyring expecting it to be unlocked before it's ready to be unlocked and then it gets all messed up. If I force a password login and just use howdy for sudo it works. So got to poke some howdy folk now :slight_smile:

1 Like

so as the solution if anyone else needs it I chose to disable howdy at login. You always had to provide the password at some point for the keyring so why not the login. After that it uses face for any sudo functions. To do this I did the following (remember to change user rob to your user).

Create the file with exec /etc/systemd/system/disable-howdy.service

[Unit]
Description=Disable howdy with systemd right before login prompt
After=system-user-sessions.service plymouth-quit-wait.service
After=rc-local.service
Before=getty.target

[Service]
Type=oneshot
RemainAfterExit=yes
User=rob
ExecStart=/bin/bash -c 'sudo howdy disable 1'
[Install]
WantedBy=multi-user.target

Then create the file with exec ~/.config/systemd/user/enable-howdy.service

[Unit]
Description=Enable howdy with systemd right after login

[Service]
Type=oneshot
RemainAfterExit=yes
ExecStart=/bin/bash -c 'sudo howdy disable 0'
[Install]
WantedBy=default.target

Then run these commands in the console.

systemctl --user enable enable-howdy.service
systemctl enable disable-howdy.service
systemctl daemon-reload
1 Like

I forgot 1 thing. You need to sudoer file

Make the file /etc/sudoers.d/howdy with the code

rob ALL = (ALL) NOPASSWD: /usr/local/bin/howdy