Lagging when play video, Kdenlive

Hey!

I'm trying to edit movie in kdenlive. But when I'm going to play the movie, it's lagging. Why? Can't find any setting for using RAM and no setting for fps ... But maybe that's not what I should set? Tried running "openshot" and the same thing happens there ...
Before I installed linux zorin lite, I had MacOs on the computer and ran "filmora" and then it was never a problem ....
Hope you can help me!
Greetings
Stefan

Hello, please post the output of the second command (in the terminal). It wil tell us about your system from hardware to driver.

sudo apt install inxi
inxi -Faz

Hi

CPU~Dual core Intel Core i5-5250U (-MT-MCP-) speed/max~908/2700 MHz Kernel~5.4.0-74-generic x86_64 Up~3:44 Mem~2535.7/3838.6MB HDD~1121.5GB(18.4% used) Procs~237 Client~Shell inxi~2.3.56

I can only get the resolution on the monitor up to 1300x700 something? Are there drivers to increase it to 1080x? Maybe that's why it lags?

This definitely sounds like a Graphics Driver issue.
How about

inxi -G

to print out your Graphics info?

hi, thanks for all your help! i get this -
raphics: Card: Intel HD Graphics 6000
Display Server: x11 (X.Org 1.20.8 )
drivers: modesetting (unloaded: fbdev,vesa)
Resolution: 1366x768@60.00hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 6000 (BDW GT3)
version: 4.6 Mesa 20.0.8

Everything looks good except for this line. "Unloaded" means that the system started using the driver, then unloaded it onto the generic driver due to something not working.We will need to do more troubleshooting, but I need to work on a car at the moment.

Do so :slight_smile: I need to take a beer - it's friday!

1 Like

While nursing your hangover, can you try the following:

sudo touch /etc/X11/xorg.conf

To create the file, then to edit it:

sudo nano /etc/X11/xorg.conf

In the window, ctrl+shift+v to paste in

Section "Device"
Identifier "Device0"
Driver "intel"
EndSection

Press ctrl+x to exit, then hit the y key to say yes to save, then enter key to save as current configuration.

sudo reboot

and test.

You may need to install this... I doubt it. But just in case:

sudo apt-get install xserver-xorg-video-intel

Hi!

then i just type "sudo touch...", then computer said that the catalog does not exist... So i did:

stefan@stefan-MacBookAir:~$ sudo apt-get install xserver-xorg-video-intel
LĂ€ser paketlistor
 FĂ€rdig
Bygger beroendetrÀd
LÀser tillstÄndsinformation
 FÀrdig
NÄgra paket kunde inte installeras. Det kan betyda att du har begÀrt
en omöjlig situation eller, om du anvÀnder den instabila utgÄvan
att nÄgra nödvÀndiga paket Ànnu inte har skapats eller flyttats
ut frĂ„n ”Incoming”.
Följande information kan vara till hjÀlp för att lösa situationen:

Följande paket har beroenden som inte kan tillfredsstÀllas:
xserver-xorg-video-intel : Beroende av: xorg-video-abi-23
Beroende av: xserver-xorg-core (>= 2:1.18.99.901)
E: Kunde inte korrigera problemen, du har hÄllit tillbaka trasiga paket.
stefan@stefan-MacBookAir:~$ ^C
stefan@stefan-MacBookAir:~$ sudo touch /etc/x11/xorg.conf
touch: kan inte beröra '/etc/x11/xorg.conf': Filen eller katalogen finns inte

Whats next :wink:

Try

sudo nano /etc/X11/xorg.conf

Then copy and paste these lines into the editor it opens:

Section "Device"
Identifier "Device0"
Driver "intel"
EndSection

Press ctrl+x to exit, then hit the y key to say yes to save, then enter key to save as current configuration.

Hey! It worked, or the computer did not protest in any case. But I still can not increase the resolution to more than 1366x768 .... And I have noticed that when starting the computer I get an error message regarding moklistrt (?), "But since safe startup is disabled, zorin starts as usual ...". ..

You can change your Screen Resolution using the Xrandr tool:
https://medium.com/@AbhiXpert/add-change-the-custom-resolution-of-your-display-using-xrandr-on-ubuntu-18-04-in-a-minute-338caec6e29

:slight_smile:

1 Like

sudo xrandr --addmode Virtual1 "1920x1080_60.00"

Does not make this command work ...

Says he does not find "virtual1 ..", what should I write?

Tested in any case to run kdenlive again and it is the same problem .... Suggested action(?), please!

His says "virtual1" because he is running in VirtualBox.
You can use

xrandr

to see your output motnitors. On mine, I have two monitors connected: HDMI-1 and VGA-1. A Notebook may show "Screen 0".
If, for example, you are using hdmi:

sudo xrandr --addmode HDMI-1 "1920x1080_60.00"

Are you experiencing lag, still?

Hi! Thanks for your patience!

Yes, unfortunately the problem remains ... Have run 3 different editing programs and have the same problem in all of them .... But could it have something to do with the resolution on the screen being set too low?

Have done after your description and tried to write it in different ways (see below), but the computer always seems to have something to complain about :frowning:

stefan@stefan-MacBookAir:~$ sudo xrandr --addmode screen 0 "1280x720_60.00"
xrandr: unrecognized option '1280x720_60.00'
Try 'xrandr --help' for more information.
stefan@stefan-MacBookAir:~$ sudo xrandr --addmode screen0 "1280x720_60.00"
xrandr: cannot find output "screen0"
stefan@stefan-MacBookAir:~$ sudo xrandr --addmode screen0 1280x720_60.00
xrandr: cannot find output "screen0"
stefan@stefan-MacBookAir:~$ sudo xrandr --addmode screen 0 1280x720_60.00
xrandr: unrecognized option '1280x720_60.00'
Try 'xrandr --help' for more information.
stefan@stefan-MacBookAir:~$ A

The only way it could is if you have Fractional Scaling enabled.

You must run

xrandr

and find in the output of that the Monitor Device I.D.
In my case, it looks like the Highlight in Red you see here:

Replace screen 0 in your command line with what you I.D. in xrandr as above.

You might try rebooting- sometimes the commands work after reinitialization.
Try:

xrandr --newmode "1280x720" 74.11 1280 1392 1440 1648 720 723 725 750 +Hsync +Vsync

I found it, "EDp1" :slight_smile: Thanks! Did not receive any error messages. But if I go under settings, it still says the same resolution 1300x ... But it may not change !?

Well! That is not the main problem. Can live with a little lower resolution, but must be able to edit my movies! But you do not think that the resolution setting is the cause of the problem with lagging in the movie editor ...? Do you think it helps to change the distributor of Linux (peppermint?)? ... and if so, to what? But as I understand it, Zorin requires less computer capacity ...

Try setting it in terminal now that you have added the newmode:

xrandr -s 1280x720

In this regard, if I were to make a recommendation for a Graphics Capable distro it would be Pop_OS

I do not for a variety of reasons; but please always remember that I am a novice. There is far, far more about what goes into a Linux system than I know or understand. You could be right and it is possible that setting a different resolution may resolve that. I would hedge bets that fractional scaling or Refresh Rate would have a far more pronounced effect, though.

Also- Please take a review of this article (and video) about Kdenlive choppy playback while editing:
https://www.netdip.com/2018/03/how-to-make-kdenlive-perform-better-and-stop-stuttering

1 Like

You're a genius, it worked! The resolution is now 1280x720! Can't thank you enough! Will be back soon, will see if there was a difference in kdenlive :slight_smile:

1 Like

Also, please do check that Link I posted up above about Proxy Clips.