Laptop is unresponsive

I have a problem with freezing on my laptop on linux (on windows 10 it works just fine).
When it freeze laptop doesn't respond to mouse or keyboard so i always have to hold a power button for few seconds.I tried few distros but problem is still there. Specificatioons of my laptop:
Asus F751s
pentium 3700
8gb ram
250gb SSD

In an effort to isolate if the D.E. is responsible, can you please outline which distros experienced freezing?

I see you are dual-booting - how much space did you allocate for the root ('/') file system? You did not create a swap area did you? Not needed on SSD.

1 Like

I tried Zorin OS, Kubuntu, Feren OS, Q4OS (Debian based) and Elementary OS.

1 Like

Definitely not the D.E., then, as that covers several different ones. It also covers several different kernels.
This could be Graphics:
Please relay the output of

sudo lshw -C video

You can check your journal logs:

sudo journalctl -f -pwarning

I actually don't dual-booting.After tried a lot of distros i decided to install windows 10 and see how it works.

Sorry but i don't have linux installed anymore. Can i try that in live usb?

Only the graphics info:

sudo lshw -C video

The journal logs are no longer present.

description: VGA compatible controller
product: Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
logical name: /dev/fb0
version: 21
width: 64 bits
clock: 33MHz
capabilities: pm msi vga_controller bus_master cap_list rom fb
configuration: depth=32 driver=i915 latency=0 resolution=1600,900
resources: irq:122 memory:80000000-80ffffff memory:90000000-9fffffff ioport:f000(size=64) memory:c0000-dffff

IF this is due to the Intel integrated graphics, you might have success with the parameter:

You really would need to test this on an installed Distro to be sure...

1 Like

Sorry for late reply. Im a beginner at linux. How can i set that parameter?

Me too.
You can set a grub parameter in the Grub File located at /etc/default/grub

How you do this is based on your comfort zone. You can use a GUI Method or the faster, but more intimidating looking terminal method.
The terminal is fast, easy and efficient and using it is good practice to increase your confidence. But I will outline both since comfort and confidence go hand in hand.

Launch terminal and run (you can copy and paste)

sudo nano /etc/default/grub

Where sudo is SuperUserDO (as in, Do This). Nano is the Text Editor application for terminal and the rest is the path to the file.
Once it is opened, arrow key down the parameters line:
Adding the above parameter is just pasting it in. It will look exactly like:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_idle.max_cstate=1"
You can right click to paste from the menu or use keyboard shortcut ctrl+shift+v
Once done, tap ctrl+x to exit the editor, then the y key to say yes to save, then the enter key to save current configuration (you will notice that Nano prompts on each of these and the above is following the prompts).

The terminal will revert to normal appearance. Now you must run

sudo update-grub

for the changes to take effect.

GUI Method:
You must elevate to root, first. So open a terminal and run:

sudo -i

Once authenticated, launch your file manager:
For Pro and Core:


For Pro Lite and Lite:


Navigate to the path above. Pro and Core users tap "Other locations" in the left pane, then "Computer" in the right pane. That will take you to Root.
Pro Lite and Lite users tap the Up Arrow Icon on the toolbar twice. That will take you to Root.

Once in Root you will see the etc folder. Open it, then the default directory. This will contain a file named grub
Right click and open that with Text Editor of your choice.
From here, follow the edits made in the Terminal Instructions above.
Save the file when done, then in an open terminal, you must run

sudo update-grub

for the changes to take effect.

Reboot to test.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.