Laptop keyboard map change

It’s already off…

Bicyu… I hate your computer. :face_with_head_bandage:

Well, for fun… I wonder what would happen if you turn it on?

Now that you switched to Main Server, which it should have been all along (And it may relate to your updates since it was not on Main), you might paste into terminal

sudo apt update

followed with

sudo apt dist-upgrade

Hey, get in the hate line mate!
No queue jumpers here thank you.

Re main server- I have no idea where that is- Ireland- but for China it is too slow and usually ends with it timing out- and as it did this time. I will not use China for obvious reasons. So I use either Korea or Japan! So there!

When I turn it on- we think alike- it just told me it would be activated next rerun or something.

Seeing as it is in MAIN server now, I will run those commands and see if it updates- can I only do that from MAIN? Why not Korea?

I honestly do not know the answer to this question. I do know that I have noticed that for international users (I am in the USA) that often, not being on the Main Server leads to things missing. An example in this very thread was that you could not install a very common app until you switched to the Main Server.

True!

The update timed out trying Vivaldi [don’t use it anyway] and something else, but the upgrade went quickly.
Not much to it- this is what you were expecting?

R anny@onyx:~$ sudo apt dist-upgrade

Reading package lists… Done

Building dependency tree

Reading state information… Done

Calculating upgrade… Done

The following packages were automatically installed and are no longer required:

libegl1-mesa libllvm9 linux-headers-5.3.0-40 linux-headers-5.3.0-40-generic

linux-image-5.3.0-40-generic linux-modules-5.3.0-40-generic

linux-modules-extra-5.3.0-40-generic uno-libs3

Use ‘sudo apt autoremove’ to remove them.

The following packages will be upgraded:

python3-apport python3-problem-report

2 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.

Need to get 92.6 kB of archives.

After this operation, 0 B of additional disk space will be used.

Do you want to continue? [Y/n] y

Get:1 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 python3-problem-report all 2.20.9-0ubuntu7.18 [10.3 kB]

Get:2 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 python3-apport all 2.20.9-0ubuntu7.18 [82.2 kB]

Fetched 92.6 kB in 2s (51.8 kB/s)

(Reading database … 313032 files and directories currently installed.)

Preparing to unpack …/python3-problem-report_2.20.9-0ubuntu7.18_all.deb …

Unpacking python3-problem-report (2.20.9-0ubuntu7.18) over (2.20.9-0ubuntu7.17) …

Preparing to unpack …/python3-apport_2.20.9-0ubuntu7.18_all.deb …

Unpacking python3-apport (2.20.9-0ubuntu7.18) over (2.20.9-0ubuntu7.17) …

Setting up python3-problem-report (2.20.9-0ubuntu7.18) …

Setting up python3-apport (2.20.9-0ubuntu7.18) …

ranny@onyx:~$

I’m thinking we gave it our best shot here buddy but…
I am inclined to reinstall the O/S now.
I am guessing you are not part of ZORIN, so I might copy this and send it to their support devs- just for their info!

Was not sure what to expect. Looks like python3 was only upgrade needed.

Reinstalling the OS seems like a major hassle when facing doing it. But I can tell you from LOTS of experience doing it (In exploring how things work, I have fried my system many times. I tend to poke around in root doing things I shouldn’t to see what will happen if I do…) that once done, it never was as bad as feared.
The most important thing is to BACKUP your Home Folder. You might ignore the .config and the .local folders this time around…
Once installed, switch to Main Server again before installing your apps.

Sad to say, that dconf-editor idea was the last trick. Outta ideas after that.
Setting xkb in terminal should have worked and that the setting in gsettings was already off… I am at a loss.

Well, hassle is relative. We have spent 2 days on this and I had a day before on it- so, in the scheme of things, a re-inst is not so bad!

You gave it everything and I for one greatly appreciate your time in helping me.
Cheers

Hi @zabadabadoo- just following up on your start- tools- input suggestion. In my grid set up it is listed as simply Input Method. I compared the faulty device with this one, they were identical.

To be sure I then reset the default US and removed all others. Restarted- still same issue.

But curiously, the top bar still showed the other language alternatives. Even though they had, I thought been removed. They also worked, for example, I was able to switch to and type in Chinese.

However the bug was evident there also because even though it displayed Chinese characters it was in fact gibberish.

I am WAY WAY out of my depth here, but at a guess it would seem that what ever changes we make via the keyboard, either pasting or typing aren’t being auctioned. That might account for why your setxkbmap us failed @Aravisian

Cheers all, dinner time.

@Bicyu, OK I have been offline this morning and have just read though today’s sad exchange with @Aravisian trying to sort it out. My suggestion to do Region settings screenshot was to see if that gave any clues, also the Input Method ref again to see if any discrepencies. Sometimes a OS re-install is the least gruesome option if you have planned ahead with Home partition backed up and list of apps you have added. (I have taken screenshots from “Software” to list my installed apps and extensions.)

I have also found a terminal command to show all installed apps useful:

dpkg --get-selections | awk ‘{print $1}’

Which I copy and paste the terminal output to a text file and save in Documents.

1 Like

Ah. That may be more compact than 5 picture files.

1 Like

And you can copy /paste package names right over into terminal or Synaptic with ease.

It was a great suggestion and I followed it through with the same idea. But, as I said, everything checked out.

I used to run Ubuntu and was very familiar with having to reinstall the O/S- but for, what, 3 years ? I have been spoilt by Zorin so I am into rusty territory now.
I don’t have too many apps etc to back up and all my docs and vitals are held on a portable drive, we also have 4 other machines here all backed up so it’s just my DT tweaks and settings.

I would sincerely like to thank both of you for your time and suggestions. I really appreciated it.

I still don’t know why the commands we inputed were not saved or actioned. Looking at everything it is exactly as it should be, yet that is not the reality. It is as if there is something else wrong that is stopping what we do in the keyboard settings from working. I guess that is one of the mysteries of the universe!

2 Likes

@Aravisian @zabadabadoo @swarfendor437
SOLVED!
Guys, you are NOT going to believe this, but after a re-inst and setting my machine back up I pressed the F11 / FN key.

On my old Acer Travel Mate at least, this switches between numb lock and full screen. Numb lock turns the P to * and other weird things.

In short, I accidentally replicated the issue that stumped me for almost 4 days!

Sadly though the 5, 7, 9, -, and [ do not work at all.
That maybe old age or some other issue but at least I know that with the exception of the [ and - keys I can find the digits using FN / num lock!

I vaguely seem to recall that even the - and [ were in there somewhere too.
Hope this little gem helps someone, sometime in the future.
Thx again everyone.

3 Likes

So @swarfendor437, was on the right track with his post early on:

i.e. Numeric key functions set by Num Lock where keyboard has no separate Numeric Keypad area.
Swarf will be unstoppable after hearing this is the solution. :joy:

2 Likes

@Bicyu, move over about half a meter and give me some of that wall to bang my head on.

You rang? :rofl:

Is this because the thread didn’t get to triple digit number of posts? :stuck_out_tongue_winking_eye:

2 Likes

Yes, he was- sadly, it was a little too cryptic so I missed it.
But well called none-the-less. @swarfendor437

It is a bit bloodied now, sorry @Aravisian