Laptop keyboard map change

Hello, after using Zorin without a hitch for several years, today my Acer keyboard seems to be working to a different input than US English.

For example, the A key prints something else, the i key shows 5, the p key shows * and the 0 shows /.
Several keys do not work; [ - 9 7 but I can’t rule out that is not a hardware issue yet.

I have determined the issue must lie in the OS somewhere as I CAN log in using a password that contains both a and 0.
However, once Zorin loads, those keys malfunction so trying to anything else that requires a PW is futile.

What have I tried?
Removing the US input and reinstalling it.
Changing from ibus to default.
Repair option at start up.
Boot repair [desperation creeping in]
Trying to update software- but it asks for password!
Reinstalling Zorin but don’t want to lose my current settings, tweaks, software, apps etc.

Extra info but probably useless
My language is set to UK, Zone NZ English.
I also have Chinese [smart pinyin], French and Japanese options.

If someone can throw some light my way it would be hugely appreciated- other than a reinstall of Zorin of course.

Obviously, I am using another machine to write this.
Thank you very much.

1 Like

Could you please paste this into terminal on the affected machine, then test your keyboard and see if it works properly?
EDIT: Sorry, outdated. Should be us, not en. Fixed below.

setxkbmap us

Blimey, you ARE quick!
Will do so and report back- but will take me a while to get to other machine~

If the above works, try swearing using your keyboard. :wink:
Just not on here. :smiley:

Let me start over… If the above works, then we know it is likely a Gnome Default Settings issue, not the keyboard or port. If it works, it may stop working later… so we will want to continue troubleshooting after.

Sorry for the delay, had to come back here to also email myself the password to my email client!
The result is: setx2b0a* 4s

Same after a restart.

did you paste it or type it into the terminal?


Hmmm, ok, what happens if you try entering the command from tty?

Uhhm you’re going to have to talk me through TTY I hve never used it, sorry.

hit ctrl+alt+F1 to enter tty. You will need to ensure you write down or memorize the command, first. You will be unable to paste it in and will need to type it in.

setxkbmap us

To exit the tty and get back to your desktop after, hit ctrl+alt+F7

Ctrl,alt,F1 logs me out!
But this time the PW is not accepted- so, in theory, we are still in the OS?

I can’t exit or return to where I was even with the F7 option.
So we are now rebooting the other machine.

This must be the worst bug ever… It affects the keys you need to use to solve it.

If you get it booted up, let’s try a GUI approach (I have my doubts about this approach, but with the keyboard rebelling at every turn…) Under Settings, Keyboard, Input tab, look near the bottom for “Layout Options”.
Screenshot or state what is in there.

OK, haven’t done that yet, [this time] but I did go down that route earlier- if I understand you. The image is of the US keypad, BUT when I press p on my pad, the * lights up on the screen.
Let me know I I mis understood!

Ah, I see. Well, another option is to open a text editor and try to figure out which keys are mismapped
Figure out which key makes ‘k’, which makes ‘m’, ‘p’, ‘u’ and ‘b’. Then transpose them in typing the command into the terminal to make the right command.

Hang on, I am on the wrong train.
Under SETTINGS I do not have a keyboard tab.
I do have a DEVICES tab which has keyboard but that is mostly short cuts. Is this relevant?

My above comment was using language settings.

I may be as well. I do not use the Gnome D.E. I am on Zorin Lite and using Cinnamon Desktop instead of XFCE.

Please take a look at this link and scroll down to

Sorry [ you can swear now if you wish] but I also tried that.
I need to re test for exact detail but, for example, if I press p and see *, pressing * does not give me p.
From memory, there were some keys that did not show up.
My thinking then as aha, the French, Chinese or Japanese Key board is engaged!

However, I did not try your idea of trying to build the command in terminal - but if you mean the setxkbmap us command, I could actually paste that in- as shown in screen shot. It just didn’t change anything.

Mapping the keys may take me a while- I just want to confirm my understanding before I go downstairs - again- and do that.

Oh, I already have.

ok, so the pasted command entered correctly but did not change the keyboard input. That is odd…
Can you look in the directory /usr/share/X11/xkb/symbols and check that the language files are present?

I need to make the nightly drive to the airport here and will not be back for about an hour and a half. If you reply during that time, I am not ignoring the thread while beating my head against the wall.

Mate, I think we are even on the wrong planets!
I’m using Zorin core tweaked.
Will check that link- thanks for your help.