Laptop keyboard problem- writting for itself

Hi there I must say I am under linux mint (hopping to turn to Zorin after next Monday) However this post is about a hardware problem so maybe My laptop keyboard started writing for itself. I clean the keys, make sure the hard disk had enough space,etc.
Finaly I discharged the software problem, since most of the time I could see how how the tabs/options in Bios were affected by it, they changed alone. Also under zorin USBlive
So I detached it from the motherboard, but cannot see at plain eye there is a circuit or line broken in the flex cord. On the contrary I have a line cut at the power (turn on button) cord and I don’t have problems to turn on my laptop :wink:

I wonder: how they keyboard could get broken? I have never detached it before or opened the laptop to get any near to it. In the meantime while trying to search for a solution I removed the key that was related to the character that get written on the screen but finally while trying to put it back I broke it (this was because another character started to be written).
Anyway here in Argentina laptops keyboards are expensive and i don’t need it right away because I use an external keyboard, but it would be nice to get it repaired o find a replacement for when I need it.
Could it be a problem of the mother board?. I would love to hear your opinions.

Would be interesting to know make and model of notebook. I bought my youngest an Asus Zen Notebook for University studies and her keyboard stopped working with certain characters. I had to get a replacement keyboard, and advise not to prod the new one heavily! I was lucky to get one as Covid had caused a lot of tech shorfalls, and even more lucky to find a guy who I always recommended for Notebook repairs who did it for free - just to be clear I had to pay almost £100 for new keyboard - the labour charge was free as I did not want to risk doing it myself - and it had just gone outside of it's 2-year warranty. Aaaargggh! I feel your pain!

Nice to meet you here, and once again!! ;D. I am sorry for your problem.
My notebook is not a known brand it is assembled in my country with Chinese parts. Brand Bangho Model futura b251xhu.
Here its specs:

  Type: Laptop System: BANGHO product: MOV v: MODEL_EQUIP serial: <filter> 
  Mobo: BANGHO model: MOV v: D02A serial: <filter> BIOS: American Megatrends 
  v: 1.01.15RPCD1 date: 07/11/2012 
  ID-1: BAT0 charge: 46.9 Wh condition: 46.9/48.8 Wh (96%) 
  Topology: Dual Core model: Intel Core i5-2450M bits: 64 type: MT MCP 
  L2 cache: 3072 KiB 
  Speed: 798 MHz min/max: 800/3100 MHz Core speeds (MHz): 1: 798 2: 798 
  3: 798 4: 798 
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics 
  driver: i915 v: kernel 
  Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1360x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 3000 (SNB GT2) 
  v: 3.3 Mesa 20.0.8 
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio 
  driver: snd_hda_intel 
  Sound Server: ALSA v: k5.4.0-100-generic 
  Device-1: Realtek RTL8188CE 802.11b/g/n WiFi Adapter driver: rtl8192ce 
  IF: wlp2s0 state: down mac: <filter> 
  Device-2: JMicron JMC250 PCI Express Gigabit Ethernet driver: jme 
  IF: enp3s0f0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Local Storage: total: 465.76 GiB used: 362.50 GiB (77.8%) 
  ID-1: /dev/sda vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB 
  ID-1: / size: 27.44 GiB used: 17.03 GiB (62.1%) fs: ext4 dev: /dev/sda2 
  ID-2: /home size: 430.39 GiB used: 345.47 GiB (80.3%) fs: ext4 
  dev: /dev/sda4 
  System Temperatures: cpu: 49.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 213 Uptime: 7h 13m Memory: 7.68 GiB used: 3.56 GiB (46.4%) 
  Shell: bash inxi: 3.0.32 

Anything here any use?

thank you, i will take a look and come back.
My doubt remains, how could the keyboard get broken' , i never spill liquids over it, i wonder if the dust i found inside the mother board could increased hit... i often clean the cooler fan but this was the first time I open the whole thing and found they motherboard really dusty .

If it's a membrane type keyboard like the Asus, not as robust as the 'X' or scissor type key keyboards.

1 Like

sorry my friend i don't understand what you mean, could you rephrase please, english isn't my native language , but anyway i think there is something missing, sorry.

I believe that @swarfendor437 is suggesting that time and use /movement of the cable has caused the damage.
The material it is made out and the design are not as strong as some other types.

Thank you!.

Use DeepL Translate to translate the web page into your language friend.


Cool. Thank you I understood mostly everything ; ) I think my keyboard is a Membrane one. ; )
You know I never spill liquids and the flex cord is short, very closed to the motherboard, so there were no chance for me to move it. So I think in general the keyboard must have reached its cycle of life.
Thank you everybody for your replies , i am going to install Zorin 16.1 today - Though i preferred to install 16 but cannot find the file in the download official web site - P.S. if you guys could take a look at this post Is this disk Ok for instalation? I will be thankful.

Get 16.1 Core from this page:

You need to scroll down - you can sign up for the newsletter or skip and continue to download when you click on Download.
As for GPT and SSD (not SDD) I don't know enough about GPT. I use mbr. As for Ext4, Ext2 would be better as journaling file systems shorten the life of SSD's - that is why Netbooks with Windows on with SSD's always came with FAT32 systems such as XP and not formatted to NTFS.

I was aiming for version 16 since I guess I supposed it has more development. I always use previous versions in fact in LM i am under 19.3 when they are in 20.1 i think. Anyway I tried 16.1 on virtual machine and it looks nice. Regarding SDD life I had to set a configuration to activate trimm (which i don't know it by hard)

If you are wanting earlier versions of Zorin then browse here:

Ignore the 'deprecated' bit - that just means for current release - just click on the version number you are interested in and then choose the DE you are after (Core = Gnome, Lite = xfce)

1 Like

Thank you.

Lstest update, as a friend of mine suggested, I cleaned the contacts of the flex cord with a cotton stick but the problem didn't go away, I left the keyboard unattached an noticed that whenever it started writing, if i lifted a bit up or move it a bit, the problem disappeared. However after i tried to plug it while the computer was on, some keys stopped working just Intro or back delete or number 7 on the keyboard pad at the right. I will buy a new one but i wonder , if the problem is on the motherboard, before buying a new one.

Problem solved by buying a new keyboard , the part wasn't easy or cheap to find in my country.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.