Laptop stuck at boot when AC pluggedin

Hi guys.

I have found a really strange bug. When AC is plugged in, then the laptop gets stuck. My laptop is a Lenovo Legion 7, with a NVidia gtx 2070 super. The BIOS is set for "dynamic graphics", and NOT "discrete graphics" as it causes an entirely blackscreen. The laptop boots fine without AC plugged in, and once Zorin has started I can plugin the AC without issues.

During the grub printout, it gets stuck related to the gfx. I will upload a screen shot if it helps, and people cant identify the issue from the description.

This issue seems to be reported here: [SOLVED] Failed to start Load/Save Screen Backlight Brightness / Laptop Issues / Arch Linux Forums

With the solution being

GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_backlight=vendor"

Anyone understand this, and have the time to explain?

The acpi_backlight=vendor changes the order of backlight drivers, how they're searched or loaded. It's so that the vendor drivers are loaded first instead of loading a generic one from the kernel :grin:

So, in your case: since the backlight is most likely 'proprietary', generic ones won't work. With your AC adapter in, that changes some things - one I'm guessing is the backlight driver.

Did adding that line in Grub fix the issue; or have you tried?


Ah, makes sense. Thanks

Didnt have the chance to rey it, but I will try it today.

Had to download all the games from steam... let them complete.

1 Like

It seems that it worked setting the acpi_backlight, (and updating grub ofc).

Noice! :sunglasses: :+1:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.