Laptop with Zorin 16 doesn't shut down or sleep

Ok no worries. Sorry for the hassle and if I've done something wrong. Someone on reddit just suggested to ask you or Aravisian

No, it is not you.
Something has happened elsewhere.

Noooo! Don't go!

Wait. Wut? What happened?

Maybe unrelated, but i was having the same problem just a week ago. Zorin won't shutdown, no matter what. Been trying everything i could find, like turning off suspend, setting power button to poweroff, using 'poweroff -p' command, editing GRUB, but to no avail. Even livebooting Zorin 16 Lite failed to power off my laptop.

Turns out, for me, it was something to do with the latest Linux kernel. It was upgraded from 5.11.0-40-generic to 5.11.0-41-generic a week ago. Booting with 'Advanced options for Zorin' and selecting 5.11.0-40-generic kernel does the magic and managed to shutdown the laptop for good. Now i'm defaulting to boot with 5.11.0-40-generic kernel with Grub Customizer.

My laptop use AMD A4-9125 processor, might have something to do with that probably?


Great suggestion. I am curious if the O.P. will have the same luck.

1 Like

Will definitely have a go at this. Thanks for the suggestion. I'm just waiting on an SSD to arrive for my laptop so I can install Zorin 16 Lite on it.


So I've got my SSD and installed Zorin OS 16 Lite on it and I'm still having this issue.

The kicker is I don't have the option to use the 5.11.0-41-generic kernel because its not even installed.

No dice since that kernel version isn't included with the new Zorin OS 16 Lite ISO

Not having this with 15.3 Lite... Are having it with Zorin OS 16 Lite or Core...

Which kernel is running on your installed system?

uname -a

So yeah I didn't have it with 15.3 Lite but I'm having it with 16 Lite and Core. I'm using 16 Lite at the moment.

uname -a only brings up the 5.11.0-41-generic kernel

If you are willing, let's try the 5.8 LTS kernel and see if it helps. There's no harm in trying it, after-all.
My only guide in this is that it worked properly on 15.3, so I wonder if there is a regression on your hardware in the later 5.11 kernel.

sudo apt install linux-headers-5.8.0-63-generic linux-modules-5.8.0-63-generic linux-modules-extra-5.8.0-63-generic linux-image-5.8.0-63-generic

Reboot into the 5.8 from the Advanced Options... menu and try testing... It may take a couple tries.

1 Like

I'll try that now thanks. I should add I didn't always have this problem with 16 Core. It started happening a week or less before 16 Lite dropped

1 Like

That was about when the 5.11.0-41 kernel came down the pipe, actually...

Yeah I've edited the install code you sent me to try install the 5.11.0-40-generic kernel that I was using before. If that doesn't work then I'll try the 5.8 kernel you listed

1 Like


5.11.0-40-generic both shuts the laptop down and suspends it. Guess it just didn't like 5.11.0-41-generic


Awesome. With that done, you might use this guide to help you set up your kernel boot to remain on 5.11.0-40 so you do not need to apt-mark hold the kernel and can freely allow updates:

I've tried that a few times but it always defaults back to the 5.11.0-41-generic kernel.

That might be because I used Grub Customizer to load the 5.11.0-40-generic kernel.

All in all I've ended up just using Grub Customizer to default to the 5.11.0-40-generic kernel.

Thank you so much for your help @Aravisian and you too @mardijker. Its honestly such a relief to have it all working again


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.