Laptop with Zorin 16 doesn't shut down or sleep

So I'm having an issue with Zorin OS 16. When I try to shut my laptop down or put it on sleep the screen turns black but the power button light stays on and the fans keep going. The laptop stays in this state until either the battery dies or I long press the power button.

I first experienced this on the Core version which was installed but also experienced it on the Lite version on a Live USB.

I'm not having this issue with 15.3 Lite which I installed after the issues started with 16 Core.

It's an HP pavilion laptop with a dual core AMD APU (cant remember the exact model) and an AMD R7 M340 GPU

Edit: The CPU is an AMD A9-9420 with built in R5

1 Like

Did you try playing with the options under Settings -> Power?
If I recall, some of them are set to Suspend as the default outcome if you press your power button. Change that to shutdown and see what happens.

1 Like

Yep I've done that but it didn't change anything. The same thing happens when I try to shut down from the "start" menu.

For the record even when I try to suspend the laptop it seems to just hang and won't respond to anything

So I shut the laptop down and pressed escape as soon as the screen went black and this was the output:

Note: I used a live usb with 16 Lite because I've reverted back to using 15.3 Lite since I dont have this problem. Even after pulling the live usb out the laptop stayed on (fans going, power light on) and after 5 or so minutes I had to hold down the power button

I have done a websearch which may help you for installed Z16, but running on Live USB may be different.
Have a look at these. The first will lead you to the second. I have no idea of knowing if this will help you or not.

Just checked my BIOS and I've already got boot set to UEFI without legacy boot and no CSM

@Aravisian @StarTreker

Sorry to ping both of you like this but I was wondering if either of you could shed some light on this. A few people have been having this issue but made a post on the Zorin sub reddit instead of here

Your going to have to get support from the mods, I'm shut down and leaving. Good luck!

Some more information:

I've tried shutting the laptop down using systemctl poweroff, sudo shutdown and the shut down button in the menu and setting the power button to shut down.

All have the same result.

Ok no worries. Sorry for the hassle and if I've done something wrong. Someone on reddit just suggested to ask you or Aravisian

No, it is not you.
Something has happened elsewhere.

Noooo! Don't go!

Wait. Wut? What happened?

Maybe unrelated, but i was having the same problem just a week ago. Zorin won't shutdown, no matter what. Been trying everything i could find, like turning off suspend, setting power button to poweroff, using 'poweroff -p' command, editing GRUB, but to no avail. Even livebooting Zorin 16 Lite failed to power off my laptop.

Turns out, for me, it was something to do with the latest Linux kernel. It was upgraded from 5.11.0-40-generic to 5.11.0-41-generic a week ago. Booting with 'Advanced options for Zorin' and selecting 5.11.0-40-generic kernel does the magic and managed to shutdown the laptop for good. Now i'm defaulting to boot with 5.11.0-40-generic kernel with Grub Customizer.

My laptop use AMD A4-9125 processor, might have something to do with that probably?

3 Likes

Great suggestion. I am curious if the O.P. will have the same luck.

1 Like

Will definitely have a go at this. Thanks for the suggestion. I'm just waiting on an SSD to arrive for my laptop so I can install Zorin 16 Lite on it.

2 Likes

So I've got my SSD and installed Zorin OS 16 Lite on it and I'm still having this issue.

The kicker is I don't have the option to use the 5.11.0-41-generic kernel because its not even installed.

No dice since that kernel version isn't included with the new Zorin OS 16 Lite ISO

Not having this with 15.3 Lite... Are having it with Zorin OS 16 Lite or Core...

Which kernel is running on your installed system?

uname -a