Larger Resolution Display Causes Zorin 16 to stop booting


Zorin 16 correctly Identifies my 3080 ti and boots fine on a 1920 x 1080 resolution display. However, after hot plugging a 1440 p display after boot the whole system freezes and becomes unresponsive. I have also tried booting with just the 1440 p display which simply hangs on the splash screen and wont reach the login screen. I'm currently using NVIDIAs proprietary 460 driver which I installed with the onboard additional drivers tool. The same occurs installing the Nouveau driver. Has anyone else had this issue?

Have you tried adding the nomodeset boot parameter to Grub?

sudo nano /etc/default/grub

Change line from GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to

GRUB_CMDLINE_LINUX_DEFAULT="nomodeset quiet splash"

1 Like

Hi thanks for your help, I just tried this and it still hangs on the mob splash screen.

1 Like

In that case, revert the grub parameter back to as it was for now, just to stay organized.
I am not sure of what the issue is so must research.

1 Like

Looking further (I am sorry, I do not use Nvidia) I found this thread

which leads to this link:

I just ran a standard System Update today which provided the 5.8.0-55 kernel from Zorin.

sudo apt full-upgrade

I wonder if the tips in that discussion apply to you - or if at least they help point in the right direction. They suggested the 5.8.0-55 kernel with the 460.73 driver.

1 Like