Launchpad subfolders, Hotcorners, "Copying" status bar prog.window not visible

am addressing 3 issues /difficulties which i've been facing for long time now-

1/ Launchpad application sub-folders - i am using layout which has launchpad application at left bottom corner. To avoid scrolling back n forth, i made few sub-folders for each icon/app according to my requirements.
My issue is - while moving from one sub-folder to another, i have to press "Esc" each time, instead of clicking the mouse to make the sub-folder disappear and move to another... for reference, you can picture macos launcher...

2/ Hot-corner stuttering - Hot-corners at edge & Launch pad application stutters very often. Hot-corners and launch pad animation effect stutters & delays while going thru & fro...i have also seen my mouse arrow-cursor stuttering over it.....I am not finding that smoothness, as found in mint (i don't mean to disrespect).....but after sometime, it settles...and later it happens again...this is frequent..

3/ "Copying" status/progress popup not showing.. and this is crazy. i've also read similar topics on this forum and its still NOT fixed...
I am using Nemo by default, and there is no "copying" progress bar nor pie-chart indicator... i am transferring 8 gb data in the dark with blank progress status..that's grossly weird.... ..

I hope zorin team fix these issues..

It would be helpful if you could take a screenshot of your desktop to better understand the first issue. As far as I can tell, at least with the default layout (there are three that have the launchpad at the bottom left), there's a Back button for that purpose:

Regarding the third issue, I'm seeing a progress indicator normally on both Nautilus and Nemo while transferring 10 files of 1Gb each:

I tried this on ZorinOS 16.3 Core, which version of ZorinOS are you using?

1/ Layout used - image
Screenshot from 2024-03-08 16-58-31

2/ Launchpad application - image

3/ Launchpad application subfolders - image

4/ Nautilus - am aware of Nautilus having pie chart indicator.sorry, but i am not using this file manager..

5/ Nemo progess bar- i am using zorin os 17.1...and the copy progress bar does not appear....
see video -
I hope this get fixed soon..thanks

I need to apologize on pt 3)...launchpad application subfolders

I just realized that the mouse click is working to make the subfolder disappear.
the mouse click works on certain areas only... and i was clicking on the bottom side which was not working....
see video link as reference-

Although, it would be great - if the mouse click would work in all areas/screen..

But pls fix the Nemo progress bar issue, Hotcorner stutter.....



I can't be sure but I'm guessing that the progress indicator only appears if it takes more than some predetermined amount of time. I've noticed in the video that the transfer happens relatively fast on your machine, compared to how long it takes for my slow USB drive on a virtual machine:

This is on ZorinOS 17.1 Core, on a 5GB file. Are you able to test on a much larger file, just to increase the amount of time it takes and see if the indicator appears then?

You can create a big file quickly through the terminal with this command:

fallocate -l 10G $HOME/big_test_file

This will create a 10GB file in your home folder. You can of course choose whatever other amount or location. This operation won't actually write anything on the disk it will simply allocate space for the file, so don't worry about wearing out the disk unnecessarily.

As for the stuttering issue, I'm afraid that's something I'm not familiar with.

EDIT: I appears that there is a 2 second timeout before the window appears. So if the operation takes longer than that, you should be able to see it.

EDIT2: A suggestion, you can try switching the window display system from the login page:

Note you must log in at least once, and then log out. Only then you will see the wheel icon on the bottom right of the screen. Click on it and whichever option is selected, use the other one. Log back again and see if there's any improvement with the stuttering.

well, if the nemo progress bar worked for zorin 16, then it should also work for zorin 17

5.3 gb transfer time is 5-6 mins...cuz i did this via mint & the progress bar had to be visible...

Yes, i also tried transfering 13.7 gb mac os file, but the result is the same....

I've noticed something:

When copying a file to an external drive, I get the progress bar window prompt. The other way around, however, it only shows me a notification exactly as it did for you in the first recording.

Interestingly, when I do the same operations within Nemo, using both panes side by side, I always get the progress bar.

I repeated this test also on ZorinOS 16.3 Core and had the same behavior. For completeness I did the same with Mint 21.2 too, where it worked flawlessly there as expected. Although this is not too surprising since Nemo is developed by Linux Mint for their in-house desktop environment, Cinnamon.

My guess is that there's something in how it works that isn't fully compatible with the Gnome desktop environment in this regard.

You can simply click outside of the folder to exit it :thinking:

This may be an issue with using nemo (not the included filemanager) with the desktop icons plugin, which was designed for used with nautilus, the included file manager. This probably will not get fixed as it isn't an officially supported configuration. Additionally, because big updates to GNOME and extensions has happened since then, compatibility with older tools and integrations may not be guaranteed.

zenzen, TGrush

i hope the explanation you gave is genuine ...cuz it seems that nemo won't work with gnome...and maybe i will have to go back to nautilus....
if nemo is officially not supported or compatible with gnome, then atleast what zorin team can do officially is to add dual-pane feature to nautilus.....can i expect this..

oops!! just forgot to mention earlier -

launchpad application sub-folders -
yes, i realized this later and i am getting around it....but if zorin is providing macos or ubuntu types layout, then it should be able to function in the exact way as it is supposed to be..i.e full screen.....if clicked on any area/spot of the screen, the folder should exit (not particular areas).. - this should also be applicable for Launchpad...presently the launchpad does not exit when clicked on any area of the screen.... inorder to exit launchpad (not launchpad folders) i have to press "Esc"...

To be clear: I don't speak on behalf of anyone. What I've told you are my own conclusions, based on testing and observation.

Nemo does work on Gnome even if there are a few rough edges. The issue with progress indicator when copying files can be easily worked around by using the very feature you are requesting to be implemented in Nautilus: instead of copying the files directly on the desktop, do so on the other pane within Nemo.

I'm not sure about the folder issue but there's definitely something going on there. Most the time it works fine for me regardless of where I click (as long as it outside the folder) but there have been a few times where I have to insist a bit.

1 Like

Well yeah, Nemo is a Nautilus fork that was mostly made for Cinnamon, a GNOME fork.

That isn't currently something Zorin is working on.

The Zorin Developers have worked on-top of the Desktop Icons NG Extension to make desktop icons possible, so it would be most realistic to either file a bug there, or with Nemo.

no's ok.. i went back to the default nautilus.....and it's working good

i also appreciate, that "Folder colors" were added in the update...i just saw this yest when i defaulted back to nautilus......appreciate that....thanks to zorin team.... it does help to identify folders/content quickly thru colors...

1 Like

that's sad...but it's ok..

You may leave some feedback in the Nautilus project page. If they decide to add the dual pane option to it, it'll be much more likely to eventually be added to ZorinOS.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.