Legacy USB (2.0) and USB 3.0 doesn't work at the same time on Zorin OS 15

I’m a Windows 10 user, but was willing to try a new OS, so I picked Zorin OS because it looked pretty nice. (I had some issues installing it, but I think that’s related to the issue bellow)

I’m using a somewhat old hardware:

  • Gigabyte GA-970A-DS3P
  • AMD FX-6300
  • Corsair 4GB DDR3 667 x2
  • GTX750 1GB.

But for some reason, I can’t get it to make both USB work at same time.

I checked the BIOS, and there are some options about USB:

  • Enable Leacy USB, which is enabled.
  • Enable USB 3.0 Support, also enabled
  • XHCI Handoff/EHCI Handoff, workarounds for USB2/3
    -XHCI enabled, EHCI disabled: USB 3.0 works, USB 2.0 don’t.
    -XHCI disabled, EHCI enabled: USB 2.0 works, USB 3.0 don’t.
    -Both enabled or both disabled: no USB works on Zorin.

I tried to reset the BIOS to Recommended Settings, but no success.

I tested the USB ports that wasn’t being recognized by Zorin OS with a MatisTek USB Doctor (a very USB multimeter), and there was energy even was able to charge my phone. Just not recognized by OS.

I’m sure all USB (on motherboard) are working properly because I have no issues on Windows 10. The problem is that this motherboard has two USB 3.0 only. (front panel was overused over 5 years and sometimes doesn’t work properly, so I unplugged it)

Any idea how to make it work properly on Zorin OS 15? (For now, I have no USB 3.0 port working on Zorin OS)

And this is where the little hairs stand up on the back of my neck…

Try enabling the setting in BIOS for “IOMMU Controller”, and “XHCI Handoff” and “EHCI Handoff”.

Well, I can’t say that cheap Gigabyte mobo was bad, I never had an issue or BSoD with that.

IOMMU Controller is enabled. Enabling XHCI and EHCI at the same time leaves me with no working USB. :frowning:

I will say right away that “anecdote does not equal evidence.” In spite of this, I see a lot of questions about issues with Linux running Gigabyte MB’s. I do not know if there truly is a correlation.

That is odd. :expressionless:
Ok can you add

IOMMU soft

to the kernel line?

I know, I said just as a personal opinion.

I think I added this to GRUB_CMDLINE_LINUX=“iommu=soft”, but I am sure I forgot to update grub.

But I’m still reinstalling everything because I was so furious nothing was working correctly I wiped my SSD to try again… lol (That’s what three days trying to make it work does to you. lol)

1 Like

I was referring to what I was saying. :wink:

Understandable.
I am notorious for wiping and reloading at the drop of a hat. I just reinstalled Zorin about two days ago, actually.
When you have it up and running, if still no USB 3.0, please review this thread:

Yep, I finally made the USBs works, IOMMU=soft did fixed it.

I found someone that had almost the same issue as I having with the exact same motherboard. http://askubuntu.com/questions/841390/amd-system-fresh-install-only-usb-3-working-iommu

By the way I found a silly bug. The info (where shows the hostname, ram, gpu and drive space) reports my 120GB SSD having 240GB space… lol (I’m pretty sure I didn’t my 240GB SSD isn’t connected… lol)

just remember to have your Partitions set to Ext2 - a non-journaling file-system. Ext3 and Ext4 are Linux journaling systems - unless of course you are a daredevil using BTRFS. Oh and you will need to set up TRIM - something that Windows does normally. If you have any precious data, use a mechanical drive - if you accidentally wipe a file from your SSD it is highly unlikely you could recover it.

1 Like

TRIM isn’t baked into 18.04 or 20.04 yet? I read that from 18.04 it was set to run once a week on systems with a SSD.

Please have a look at this article, here: