Lenovo G710 zorin os 17 bluetooth problems

Hello there! Im new to zorin os. I have installed zorin os 17 pro and my bluetooth doesnt work anymore.

it did worked on 16.3 pro but on 17 pro it doesnt anymore.

can someone help me ? Other than that, Zorin OS is a very good alternative to Windows.

Can you please list your wifi radio details:

sudo lshw -C network

Does bluetooth launch but not detect devices? Or is Bluetooth not starting?

bluetooth is not starting

It looks like you are using Broadcom. Broadcom uses proprietary drivers, so you probably need to install drivers for the full functionality of the card:

sudo apt install bcmwl-kernel-source b43-fwcutter firmware-b43-installer

Tried that command, didnt work. Bluetooth is still grayed out in settings.

I am able to toogle on off button, but it still remains as off.

In terminal, run

sudo rfkill unblock bluetooth

sudo systemctl start bluetooth

Install and launch blueman

sudo apt install blueman


Try turning on a bluetooth device set to Pairing and in Blueman, try searching.
If still no good, try

sudo apt install --reinstall linux-generic-hwe-22.04 bluez

Do a full cold hard reboot, then test bluetooth.

Did all that, still no changes in bluetooth settings. It remains the same

What is the terminal output of

systemctl status bluetooth


lsmod | grep bluetooth

Everything there shows it as running and active - what is the symptom that causes you to believe it is not?
Is a specific device not pairing? Are a multitude of different devices not pairing?



i cant search for any devices and bluetooth manager doesnt open up

sudo modprobe -r btusb

sudo modprobe btusb

no change. when i toogle bluetooth off, it shows for a second in my taskbar and then dissapears when i click turn on

I am at a loss on this... It worked on 16.3?

Have you tested an earlier kernel?

it worked on 16.3 yes. and no, i havent tried, how do i do that?

You can try an earlier kernel by booting and immediately tapping esc or tab to pull up the Grub Menu, selecting Advanced Options for Zorin and selecting Zorin on 6.2.... (Do not select the Recovery option).

I'm having the exact same issue. I'm on Zorin 17 Core. When I run systemctl it says the bluetooth is running but it's grayed out in my settings.

It was working yesterday! But not today..

I rebooted on Zorin on 6.2 and that didn't work.

Are you using the same hardware as the O.P.?
If not, we should separate your troubleshooting into a new thread in order to keep things organized and avoid possible conflicting steps.

If you create a new thread on this, can you please include the terminal output for

sudo lshw -C network

sudo lshw -C video