Lenovo i9 Yoga slim touchpad issue

The first command line seems to have fixed it, it takes a few seconds when the pc boots to pick up the keyboard! Thank you!

However, it seems that the glass touch pad is also non-functioning. Could this also be resolved through continously updating grub? :wink:

1 Like

The keyboard started working but touchpad, was working but started working as soon as the keyboard started working?

Apologies, let me rephrase, touchpad was working from the start, is also still working, but very stuttery, almost like there are driver issues. Almost no recognition when tracing your finger over the pad.

Awesome, then issue resolved for the keyboard!
However, might it be that the lenovo " Buttonless glass surface multi-touch touchpad, supports Precision TouchPad (PTP)" has some sort of proprietary driver which makes it hard to interact with linux?

Can you check if you have synaptics installed with sudo apt install xserver-xorg-input-synaptics

Well, my solution was short lived... keyboard died again after a sleep mode.
I did not have synaptics installed, just installed it, now going to reboot.

Edit: Synaptics install did not help.

Ok... There may be a tool that can help with this computer...

A Hammer...

Was Synaptics already installed or did you just now install it?

1 Like

Just now installed it!

Ok, so anything we do with Synaptics is unlikely to help at this point.
Have you tried the rest of the grub parameters listed up above?

EDIT: posts moved to new thread to take one issue at a time...
Current Status: Lenovo i9 yoga slim notebook, touchpad (PTP) not working.

1 Like

I know exactly what the OP is going through, I've had both issues. With my old workstation computer that Zorin is on, the touchpad can by stuttery/twitchy just like the OP has said. And on my MSI gaming machine. My Corsair K95 Platinum mechanical keyboard, doesn't usually power up properly with the computer on the first try, and requires a restart, or further restarts, until it does connect properly.

We can't simply write these issues off as distro specific. Cause both OS's are based on Ubuntu, so all I am saying is. If we figure out what is going on with the OP's machine, the results of that, could also benefit me, as well as other's.

So I will be watching this thread closely. Also, how are things going since you installed Synaptics?

1 Like

Alright, we got the keyboard working, however the keypad is still forming an issue, I'm going to scour around the interwebs for a bit and see if I can find something.

If anyone has any suggestion regarding this issue, feel free to share :wink:

Current attempst:
Adding pci=nocrs to /etc/default/grub did not provide any changes.

Currently investigating the following:
https://itectec.com/ubuntu/ubuntu-ideapad-5-15are05-elan-touchpad-not-working-on-20-04-nor-on-18-04/
However, I'm hestiant as I don't know what a "kernel downgrade" will do to my system. Any additions are welcome!

It can be hard to tell.... But it is no big deal. All you need to do is install the older kernel, then boot into the recovery mode, select that kernel, then boot from it. Then test the results. If it doesn't work out, just reboot and the computer will boot into the higher kernel.

Fellow ZorinOS users, and who knows maybe someone in the future, at this time Lenovo does not like the 5.11 kernel. A downgrade to 5.8 seems to resolve ALL issues that I have mentioned:

  • Non working keyboard
  • Bad working touchpad
  • Weird horizontal screen flickering when scrolling/ moving the mouse

Hope this was informative :wink:

1 Like