Lenovo Ideapad S145 hotkeys not working

It says in the title! the only hotkeys that work are F1 (mute), F2 (volume down), F3 (volume up), F5 (refresh) and F9 (logout) the rest doens't work. I've tried running "acpi_listen" and it returns nothing.

Hope someone has already fixed this.

1 Like

Here is a wild idea which would not take much time to try:

PS: Which version and flavour of ZorinOS do you have. e.g. Z16Core,Pro or Z15.3 Lite etc.

EDIT: Also are you dual-boot with Windows?
Do those keys work in Windows?
Do those keys work when running ZorinOS Live USB in "Try Zorin" mode?

Let me try that.
EDIT : I can't remove the battery

I use Zorin OS Core. I don't dual-boot with Windows. Yes, they work on Windows. No, they don't work when i run a Live USB.

Again without knowing which version of core you are running it is extremely difficult to assist you. What works in 15.3 doesn't in 16 and the reverse.

Oh my version? it's 16.

Seems there is a bug in Ubuntu, you're not the only one with this issue:

1 Like

Ubuntu or Lenovo will have to address this. I'm not sure if the Zorin's modify any of the Ubuntu code. That would be for @AZorin and @zorink to say.

2 Likes