Lenovo T15p wifi works from Live USB, fails after install

I ran the Zorin OS Live USB stick on a Lenovo T15p Gen 1 and it's look great. I was able to reproduce the look of Chrome OS sufficiently for a family member.

But after installing it, the wireless card is not recognized, an Intel Wi-FI AX201. I tried using ethernet as a second way to connect to the internet, but that would only say "connecting" and not actually connect. As a third attempt to connect it to the internet, I used an USB-to-ethernet adapter that has worked with other Linux devices, but this was not recognized-- no status lights came on.

Not to be deterred, I still found a way to connect the device to the internet:

  1. I booted the device from the Live medium again
  2. Used Gparted to unlock the encrypted volume
  3. Mounted the internal drive.
  4. Connected to wireless while using the Live medium.
  5. "chrooted" into the internal drive

From there, I could run apt update/apt upgrade to get the latest updates. After rebooting to the internal drive, I confirmed that didn't fix the issue.

I studied the issue more to see what differences there could be between the live environment and the installed environment. I found some:

  1. The live environment uses "generic" kernels, while the installed environment used an "oem" kernel. There was even a special package with drivers for this hardware series, with a name like "oem-sutton.simon-addison-meta".
  2. The installed kernel was slightly newer.

So maybe there was a regression in the "oem" kernels or simply in a newer kernel.

By mounting some things from the host into the chroot, I was able to uninstall the OEM kernel stuff and re-install "generic" kernels, but that didn't fix the issue either.

Because the device doesn't have networking and it's time consuming to reboot back into the live environment and chroot on each attempt, I'm about to give up on Zorin OS and try Ubuntu 22 instead.

Clearly the hardware can work with Linux and something is going wrong during the installation.

While I'm not sure I'm going to try further to fix this, maybe these notes will help someone else on a path towards a fix. If I do get Zorin OS working, I'll report back here.

Please can you open a terminal and enter:

sudo lshw -C network

and post back the results please.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.