Lenovo T480s Fingerprint Reader (NoSuchDevice)

Hello!

I've recently purchased Zorin Pro - I'm no stranger to Linux, having run various vanilla Ubuntu LTS builds as well as headless server builds, but I would still classify myself as a noob when it comes to anymore more than basic terminal commands.

I've been trying to get the biometrics working on my T480s, and tried most of the solutions listed on this forum.

My main issue seems to stem from the fact that no matter what I try, the device doesn't recognize that I have a reader on the machine, kicking back:
Impossible to enroll:

GDBus.Error:net.reactivated.Fprint.Error.NoSuchDevice: No devices available

I've tried to enable the reader, followed by a reboot, but I get the same issue

1 Like

Maybe you can check this :point_down: and start from If Fingerprint login isn’t available.

Have you yet run

fwupdmgr get-devices

fwupdmgr refresh --force

fwupdmgr update

1 Like

Thanks @Luca_Pavan - this was where I started my journey, and I didn't have any luck with this.

1 Like

@Aravisian Yep, I did this as well - had a couple firmware updates (funny enough both of them never installed properly when I had windows as my main OS, after switching to Zorin I had zero issues!)

From what I can gather, I don't believe the sensor is being detected.. I tried other threads with various options to enable it, but no luck.

Here's what I get from get-devices

Devices with no available firmware updates: 
 • SSD 980 PRO 1TB
 • UEFI Device Firmware
Devices with the latest available firmware version:
 • Embedded Controller
 • Intel Management Engine
 • System Firmware
 • Thunderbolt host controller
 • UEFI dbx

Do I have to choose something in the BIOS?

EDIT: Checked BIOS confirmed the reader is enabled, then also cleared the old data as recommended in a thread I found about troubleshooting when it's not working, however the issue persists, the hardware isn't found:
Fprint.Error.NoSuchDevice: No devices available

1 Like

Updates: I found this thread, which exposed me to the lsusb command .. this then in turn helped me learn that my fingerprint scanner hardware's UUID is "Synaptics 06cb:009a"...

Googling this unearthed this Reddit post with a link to a git specifically for this hardware, with troubleshooting for my own error (installing this prompted the list_devices failed:, I then pushed python to validate, ran enroll again, and it appears to be working, as fprintd-enroll now works!

I was then able to navigate to settings, enabled fingerprint, and enroll successfully

I guess I solved my own issue :wink:

2 Likes

Hi, try this command: lsusb
If the fingerprint reader is on the list, try this:

sudo apt install -y fprintd libpam-fprintd
sudo pam-auth-update