Libre Math is not installing

When I click to install and enter the password, the following error message is showing. How to install it from app store?

1 Like

Assuming you have an internet connection. I am wondering if it is a server side issue. Have you tried to download from Software store on more than one separate occassion. If not wait a few hours and try again.

1 Like

Ofcourse I have a good internet connection and I installed other apps. But Libre Math is showing error since yesterday.

I also assume that it has server side problem. But it needs to be fixed asap. My country is India.

1 Like

Gday @bapi404
As @zabadabadoo suggested to try again later. This normally fixes the issue, as you know you have use the Software Downloader may times before :+1:

Your issue as you have been trying a few times to download & also you have been successful downloading in the past. This is also why @zabadabadoo asked if you have a good connection :+1: you may need to refresh your modem.

For "Libre Math"

In "Software & Updates", in both "Zorin software" & "Other software" please make sure both "Canonical" are selected.

Then try again, with refreshed modem ( if needed )

If your still unable to download.
Try selecting a "Sever" near you, (The Main Server can become overwhelmed at time's.

To change "Server", in Software & Updates.
You see "Download From", click the Arrow & select "Other", search/Select for India , Then click "Select Best Server" .

As you see in my First photo Above, i use Australian Server (.au) :+1:
It worked for me as per photo's,

Hope this may help.

Sadly your tweaks did not work. I tried all the possible methods but not successful. I changed among the servers. I am able to install other apps but not the Libre Math. God knows where is the problem!

Gday @bapi404 ,
i just ran a ping test to the above IP address .
Seems they maybe having intermitant issue's,
As you seen yesterday i was able to download/install Libre Math.
Today i have had 2 updates, now my Software centre wont open ( tried 3 times)
Now opens after reboot.

Sorry but keep trying every hour or so.

ADDED: just rebooted, now have Software centre open & reinstalled Libre math

Please run:

sudo apt autoclean
sudo apt autoremove

This may have bad cache

Please make sure you refresh modem & router/s


Still I'm not able to install Libre Math :slightly_frowning_face:. I can update or install other apps but not this.

Gday @bapi404 ,
If your trying at roughly the same time of day.
As per your OP, in your screenshot, you can see you were running the system updater at the same time.
If needed goto Software & updates & set your updates to "never", just to try to get Libre Math. (Then reinstate your auto update back to your preference.)
Alternatively, you can try installing via the terminal


sudo apt update


sudo apt install -y libreoffice-math


Hope this may help,

sroy-nux@sroy-nux:~$ sudo apt install -y libreoffice-math
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 740 kB of archives.
After this operation, 2,524 kB of additional disk space will be used.
Err:1 Index of /zorinos/apps/ubuntu focal/main amd64 libreoffice-math amd64 4:7.5.1~rc2-0ubuntu0.20.04.1~lo1
404 Not Found [IP: 80]
E: Failed to fetch 404 Not Found [IP: 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

I'm also getting this error while updating from Software.

Try Flushing your DNS cache
Read carefully as you may need to repeat some commands:

When finished , try your Software Centre again.

If you get an error checking the stats try this:

resolvectl statistics

This is just to check if it has cleared.

It may also be worth taking the terminals advice.

sudo apt update --fix-missing

1 Like

I'm tired of this. The easiest way to me is reinstalling Zorin Os.

1 Like

I cannot blame you.
I removed and reinstalled libreofficemath several times testing and checking during the course of this thread. Each time, it installed with no problems.

I have no idea what is going on with yours... The only notable difference is that I use only the terminal, never the Gnome Software Store.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.