Libre Office - ZorinOS17 Pro - GUI Font - I messed it up


I have somehow uninstalled the Zorin GUI customisations of Libre Office (ZorinOS Repository) version 7.x? (I was foolishly uninstalling things using Synaptic Package Manager and went too far....).

Now when running Libre Office, the menu text is in a poor looking font.
Just for clarity - I am not talking about the fonts in a document. I am referring to the font used in the menus, drop down menus, dialogue boxes etc
I have tried uninstalling and re-installing from the repository. No luck.

If I uninstall and install Libre Office from Snap Store I get version 24.x and the UI is great. The only problem is this runs so much slower than the Repository version.

Would anyone be able to help me identify which package I need to reinstall to make my Libre Office 7.x version look good again?!

Thank you,

You could try the Flatpak Version. I find that runs a lot better than the Snap Version.

I installed the packages manually, which took an extremely long time to get in correct order from LibreOffice website for my KDE neonuser OS!

Do you know if it was a Libre Office package you removed or a Zorin font? Could Check These packages to see if they are still installed

  • fonts-comic-relief-zorin-os/focal,focal,now 16.4.1 all [installed,automatic]
  • fonts-croscore-config-zorin-os/focal,focal,now 16.4.1 all [installed,automatic]
  • fonts-gelasio-zorin-os/focal,focal,now 16.4.1 all [installed,automatic]
  • fonts-inter-zorin-os/focal,focal,now 16.4.1 all [installed,automatic]
  • fonts-jetbrains-mono-zorin-os/focal,focal,now 16.4.1 all [installed,automatic]
  • fonts-michroma-zorin-os/focal,focal,now 16.4.1 all [installed,automatic]
  • fonts-roboto-mono-zorin-os/focal,focal,now 16.4.1 all [installed,automatic]
  • fonts-sans-forgetica-zorin-os/focal,focal,now 16.4.1 all [installed,automatic]
  • fonts-selawik-zorin-os/focal,focal,now 16.4.1 all [installed,automatic]
  • fonts-space-grotesk-zorin-os/focal,focal,now 16.4.1 all [installed,automatic]
  • fonts-zorin-os-core/focal,focal,now 16.4.1 all [installed,automatic]

if not or if one or two are missing try manually installing the missing or reinstalling

If they are there try re-installing this package

1 Like

Be sure you have libreoffice-gtk3 installed. It affects the appearance.

1 Like

Thank you to all who responded.
@Topaz - I tried your suggestion first.

  • Uninstalled Libre Office.
  • Installed the libreoffice-gtk3 via Synaptic
  • Installed Libre Office (Zorin Repo)

All looks good now, and runs nice and fast.
Thank you @Topaz


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.