LibreOffice apps and docs won't open

[in Zorin Core 15.3]
I have cleaned up with Stacer, restarted my laptop, and even tried removing the libreoffice config folder per advice on Ask Ubuntu. No dice. All my writer files are inaccessible. Please help!

Cliffe, have you tried launching Libre from Terminal? If so, does it show any errors?

Is y our copy of LibreOffice a snap install? (You can double check using either Software Channel or by running snap list in terminal.

If it is a snap, you may try using snap reinstall;
If not a snap, you might try

sudo apt install --reinstall uno-libs3

cliff@cliff-Latitude-E5430:~$ libreoffice --writer
ERROR: not connected to the gnome-3-28-1804 content interface.

Yes it is a snap. LibreOffice for Linux: latest stable release v published May 5 2021 - libreoffice_213.snap - 651.5MB
Gnome Software says "installed" but it will not launch from there, desktop or start menu. I tried $ sudo apt install --reinstall libreoffice and it fetched a legacy version: LibreOffice from 2020-02-03. It was functional, but v7.1.3.2 stilI wont launch. I finally resorted to removing LibreOffice 6.4 each of its packaged apps via Gnome Software. My only remaining way to work on existing Word or .odt files is Google Docs online.
A couple last remarks for you:

  1. See attached shot of folder that may offer clues; can you comment?
  2. What exactly is uno-libs3?
  3. What command is used to install a non-snap version of v7.1.3.2?
    Thanks so much for giving your valuable time! - CE

Uno-lib3 is part of the libreOffice runtime environment.

To install Non-snap LibreOffice 7.1.3, you can use a .deb package:


Wonderful! Thank you so much. How critical is it to ensure that the snap and all its dependencies are completely purged before installing the manual version?

I would think that the Snap Remove______ command should be sufficient.

Re ERROR: not connected to the gnome-3-28-1804 content interface.
running snap list showed these entries:
gnome-3-28-1804 145 latest/stable canonical✓ broken
gnome-3-38-2004 0+git.3d25b9b 39 latest/stable canonical✓ [not broken]
Might fixing the 1804 solve the problem of installed snaps not launching?
If so, what command would you use?
gnome-3-28-1804 --reinstall ? --repair ?

I simply don't see why "installed" snaps should suddenly quit launching, and would prefer one last try before resorting to the .deb package

gnome-3-28-1804 145 latest/stable canonical✓ broken
gnome-3-38-2004 0+git.3d25b9b 39 latest/stable canonical✓ [not broken]

Are you using Zorin OS 15.3?
The above makes it appear as though versions for Bionic and for Focal are both installed. It may be that the installation of the Focal version broke the Bionic. Very strange.

You might try connecting the libreoffice app to gnome for Ubuntu 18.04 if on Zorin OS 15.3 and if you are on Zorin 16 Beta, you will want to connect to the 20.04. Assuming you are on Zorin OS 15, try (this is Half Guesswork as to the possible command - I do not use Snap):

snap connect libreoffice:gnome-3-28-1804 gnome-3-28-1804:gnome-3-28-1804

You may need to adjust that to make libreoffice more specific -or as listed by snap list, I am not sure.
This is also a wayward shot- as Snap is listing your Gnome Ubuntu Stack as broken. Given that you have an issue with another Snap Application - this probably will need some heavier troubleshooting as to what is going on with Snap.

An Option may be to remove All Snaps - entirely. Then remove snapd. Once completed, install snapd, then reinstall all that was removed.
You can do this by performing snap list and then saving that list in a text. Then in terminal, snap remove ______ where ___ is the package name.
Then remove snap:

sudo snap remove snap-store

sudo snap remove gtk-common-themes

sudo snap remove gnome-3-28-1804

sudo snap remove core18

sudo snap remove snapd

Then reverse the order to reinstall all of the above - then reinstall your list of removed snaps from the text you saved earlier. EXCEPT for gnome-3-38-2004 0+git.3d25b9b 39 latest/stable canonical - Do not install this
Theoretically, this should restore snap and all snap programs to full working order.
That's the theory, anyway...

EDIT: Also, one more thing: If snap refuses to remove a package, just go into the Snap Directory and manually delete or remove it and that will clear that up. You can then proceed with the rest of the list. If snap refuses on each item: Facepalm twice then bang your head on the wall four and half times- then delete each item from the Snap Directory. Then proceed to remove Snap and snap components in the terminal as outlined above. Then perform the reinstalls.

Wow! Thank you! Definitely still on Zorin Core 15.3, but that command syntax gave error: snap "gnome-3-28-1804" has no slot named "gnome-3-28-1804" I tried "snap connect libreoffice_213:gnome [etc]" but got error: snap "libreoffice_213" has no plug named "gnome-3-28-1804"
BTW, I should mention that the 1804 entry no longer appears in the /var/lib/snapd/snaps folder even though it still does in snap list.
I'll work my way through the rest of this. Asking some questions in . Then may try your "final solution" (as long as removing "core" snaps doesn't disable my whole system!!)
Thanks again for being so generous with your time...

It won't. Just be sure to reinstall everything before logout or restart. But even if the power goes out and you have to do your reinstallations after booting up, your system should not be damaged by any of the above. You just won't be able to launch your snap apps until you get everything reinstalled- which you are already suffering form on some of them.

Not so generous- I am sitting around being lazy today and playing with graphical designs.