LibreOffice stopped working

Weird... I hadn't changed anything, it worked just yesterday, but today LibreOffice wouldn't open. None of them (Calc, Writer, etc.). It would briefly pop up the opening splash box, then nothing... no errors, etc.

So I tried to open if from the CLI, both as a regular user and as sudo... still nothing.

So I uninstalled from Software Center and reinstalled... same thing.

So I uninstalled from CLI and reinstalled... same thing.

So I went scorched-earth on it. I uninstalled everything related to LibreOffice, started sudo nautilus and searched for all files and directories with LibreOffice in their name (except for the icons under /usr/share/icons) and removed them, then went to the LibreOffice website, downloaded the latest version (7.6.1.2) and installed it.

It's nicer than the version you can get from the repository. It also installs LibreOffice Math, the icons are more boldly-colored, and it starts up much faster.

It's got an auto-update feature that'll prompt me to install when a new version is out.

Interesting, I have the community edition of 7.4.7.2 on my Antix Rig and that has Maths and Draw by default and no issues!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.