Linux Noob Can't assign new steam library on HDD - Read only

Hi all!

Looking for help regarding my HDD in pro. i get the error of Disc is read only or something that says executable

It's also disappeared from my file directories. so i can't view HDD in zorin

In the Zorin App Menu, type disks
Launch the offered Disks app
Select the drive that you are referencing, then click the Gear Icon.
Select Edit Mount Options.
Ensure that "Mount at system startup" is checked.
Ensure that "Show in user interface" is checked.
Ensure that "Require additional authorization..." is UNchecked.
Click OK

The option to edit isnt there :confused:

Think i've figured out what it is, reformated the drive - will update you in a second :slight_smile: also checked the mount options and additional authorisation was unchecked :slight_smile:

Ok i still seem to be having the same issue through steam am i selecting the correct place?

Is the drive mounted?

yes i think so says drive mounted at /media i also seem to have a grainy sound issue

fixed the sound issue, erasing data on my HDD now. what should i format it as?

Are you installed flatpak version of steam?
If yes install flatseal
and add add your storage medium

Anydesk is for example select Steam

And select your drive patch ex. /dev/sda2/steam-libray

You can check what is your patch to partition in gnome Discs


What is the flatpak version?

Go to the store
Then search Steam and select version that you installed
then scroll down
and tell me the source


So its flatpack

OK install app called flatseal(The flatpak permission menager)

ok i am up to here

in right menu click Steam

Scroll to filesystem

after that click add in other files
and then write a patch If you don't know how just say it i will help