Linux thinks partition is unallocated

OK... so.
Little by little, I am getting further away from Windows.
I just deleted my old windows "Storage" partition and extended my Steam partition into the empty space. Success!

Now for something that has been bugging me since I installed Zorin in the first place.
I have in my system a 3 TB hard-drive. In Windows I used to have to use an Asrock utility called "3TB+ unlocker", otherwise I had the same issue there. The issue is that I can see and use the 2.2TB partition no problem. However, the remaining 750GB are seen as "unallocated space" even though I know full well it is completely allocated and is home to my collection of TV shows and movies...well, some of them lol.
I mean, at least Linux can see it. In windows it was completely invisible until I would install the unlocker!
So my question is: how in the hell do I get Zorin to recognize the partition for what it is, rather than unallocated space?
I'm quite sure it is formatted NTFS. If it weren't so full, I'd just blow it away and redo it. But I have a lot of media on it that I don't wish to lose.
Any takers??

edit so apparently it has something to do with MBR vs GPT partition tables. I converted from MBR to GPT but my system still doesn't want to recognize it as being populated.

MBR can only manage up to Four Bootable Partitions.
Can you go into more detail about what you tired? my first guess would also be that this is related to your GPT table.
Do you see any warning about GPT listed?

1 Like

In disks, take note of the device, /dev/sda1 (the device is sda the partition is 1) and the UUID. After that, boot into Zorin, look up adding ntfs drive to fstab (there are many examples and tutorials available) to Ubuntu 20 (zorin 16's base) and add an entry to your /etc/fstab file. At the end of the UUID line, after the mount location, add ntfs-3g. This should give you full read/write access to the partition. Reboot and look in the directory.

You said that you downloaded and used an unlocker? What program did you use to stream them? Do you have them encrypted or through a particular streaming service? You would have to find a compatible application if this is the case, or unlock the files and save them under a different format to access them.

The above will still help you by mounting the partition at boot and give you full access to the drive.

1 Like

I may be totally off track here, but I had an issue where I had a different OS state that my /home partition didn't exist! I included a solution to this in the unofficial manual that I wrote for Zorin 15, page 182 to end of manual:

1 Like

Thank you for the suggestions. I gave up late last night and just blew the partition out and made a new one. I formatted it ntfs (windows has to be able to see it too, for now) and am currently downloading what shows I can remember I had.
So anyway, it was a painful delete but it's one that won't have to happen again, since it is now a GPT table rather than MBR.
Would have been nice to figure it out without losing all my shows, but I'm just happy it works now.

Thank you again! Happy Easter


I have experienced similar and I understand your pain. One thing I have noticed: If I couldn't remember the thing I lost in order to replace it, it may not have been too important.
And when you do remember it, you can usually regain it.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.