liobc.so.6

/home/noldi/Diverses/Stockfish/stockfish_22042208_x64_bmi2: /lib/x86_64-linux-gnu/libc.so.6: version GLIBC_2.32' not found (required by /home/noldi/Diverses/Stockfish/stockfish_22042208_x64_bmi2) /home/noldi/Diverses/Stockfish/stockfish_22042208_x64_bmi2: /lib/x86_64-linux-gnu/libc.so.6: version GLIBC_2.33' not found (required by /home/noldi/Diverses/Stockfish/stockfish_22042208_x64_bmi2)
/home/noldi/Diverses/Stockfish/stockfish_22042208_x64_bmi2: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.34' not found (required by /home/noldi/Diverses/Stockfish/stockfish_22042208_x64_bmi2)
n

Zorin OS comes with GLIBC_2.31

This cannot be upgraded without breaking the system.
If you are installing something that depends on GLIBC 2.33, you may try contacting the developer of that package to see if they can adjust the package to work on Ubuntu 20.04.

If you are frisky, you may be able to extract the package, change the glibc dependency in the "depends" file, then debuild the package back into a .deb file and run it through the installer.