Lite display freeze

Hi. Came from Ubuntu as was using it in past 5 years. Rock! Because I was curious about Zorin performance on an old laptop (was running 18.04) I installed Zorin Lite. It is very fast performance but freezing my display often. In 5 days 3 times. Only powe button is the solution to solve this. System i5, 64bit, 8BG, 1T HDD 7200 rmp, ATI radeon, kernel 5.4. As I see no solution about it yet. It has never happened before on same machine with openSUSE 14, Manjaro xfce, Ubuntu 16, 18, xUbuntu 18.04 and xUbuntu 20.04. I really like the speed of Zorin lite with xfce but these freezings probably will cause me back to Ubuntu.

There are many things that can cause freezing and crashing. RAM, firmware update needed, GPU… So we would need to troubleshoot with detailed information.
You might perform a memtest, as a better and faster performing system might show issues that a slower system catch up to by the time RAM has dumped memory.
Can you post the output of

inxi -fs

and let’s look at your graphics.

Hi and thank you for reply. Below are copied outputs.
Output:
CPU: Dual core Intel Core i5-2430M (-MT-MCP-) cache: 3072 KB
clock speeds: max: 3000 MHz 1: 1311 MHz 2: 1595 MHz 3: 1731 MHz
4: 1646 MHz
CPU Flags: acpi aes aperfmperf apic arat arch_perfmon avx bts
clflush cmov constant_tsc cpuid cx16 cx8 de ds_cpl dtes64 dtherm
dts epb ept est flexpriority flush_l1d fpu fxsr ht ibpb ibrs ida
lahf_lm lm mca mce md_clear mmx monitor msr mtrr nonstop_tsc nopl
nx pae pat pbe pcid pclmulqdq pdcm pebs pge pln pni popcnt pse
pse36 pti pts rdtscp rep_good sep ssbd sse sse2 sse4_1 sse4_2 ssse3
stibp syscall tm tm2 tpr_shadow tsc tsc_deadline_timer vme vmx vnmi
vpid x2apic xsave xsaveopt xtopology xtpr
Sensors: System Temperatures: cpu: 53.0C mobo: N/A gpu: 45.0
Fan Speeds (in rpm): cpu: N/A

Graphic adapter output:
*-display
description: VGA compatible controller
product: Seymour [Radeon HD 6400M/7400M Series]
vendor: Advanced Micro Devices, Inc. [AMD/ATI]
physical id: 0
bus info: pci@0000:01:00.0
version: 00
width: 64 bits
clock: 33MHz
capabilities: vga_controller bus_master cap_list rom
configuration: driver=radeon latency=0
resources: irq:39 memory:b0000000-bfffffff memory:d4a00000-d4a1ffff ioport:6000(size=256) memory:d4a20000-d4a3ffff
*-display
description: VGA compatible controller
product: 2nd Generation Core Processor Family Integrated Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 09
width: 64 bits
clock: 33MHz
capabilities: vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:38 memory:d4000000-d43fffff memory:c0000000-cfffffff ioport:7000(size=64) memory:c0000-dffff

Uname output:
Linux 5.4.0-64-generic #72~18.04.1-Ubuntu SMP Fri Jan 15 14:06:34 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

Detailed :smiley:
Well, everything looks good at that point. Your kernel version is up to date- though I have heard others claim that 5.5 is better for Radeon. That MIGHT be worth upgrading… But first…

In your /etc/default/grub file, do you have the options:

noapic acpi=off

set on line

GRUB_CMDLINE_LINUX_DEFAULT

?

Next, I see you have two graphics card ports- the onboard Intel and the radeon- Have you tried plugging your monitor into a different port to test if it makes a difference (To suss out if it is a graphics issue)?

Temp- it shows 53 degrees. That may be unusual and just a matter of timing. But that is a bit high. GPU is doing better at 45 degrees. As long as it is under 60 degrees, but I would feel more comfortable if that read about 48 degrees than 53…

Thanks. It is a laptop. I use additional monitor but didn’t chek it with Zorin OS. I found this at ATI site:
The following packages must be installed in order for the Catalyst™ Linux Graphics Driver to install and work optimally:

  • gimp-help-en
  • gimp-help-common
  • XFree86-Mesa-libGL
  • libstdc++
  • libgcc
  • XFree86-libs
  • fontconfig
  • freetype
  • zlib
  • gcc

Just installed mostly of tehm because by default Zorin OS installed to me only ZLINB. Before tha installation I froze again, just 5 min ago :frowning:
Anyway another problem occures - when change USER the screen is black again and Power button is the solution… I don’t have another registered user. Because I use HDD not SSD to prevent HDD I set up System Sleep on Lid closed. After that just pull out the battery and HDD is safe. Then start again… But this is a temporarly solution. Let see after installation of ATI requirement files how will be.

Regarding GRUB:
GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash”
but don’t have an option noapic cpi=off

As a suggestion on the side, since Aravisian noted 2 GPUs, I recommend checking your BIOS and also seeing this: Asus Zenbook Laptop Brightness not changing

Thanks carmar. I’m gonna check the links. My BIOS doesn’t have an option cho chose default graphics. No freezing since the time I installed recommended packs by ATI. Even I was opened several apps + browser + antivirus network check + smart disk check by Gnome. No freezing and no blank screens. I was using Kernel 5.8 with Focal Fossa but there was a bug that broke my virtual machines after upgrade from 5.4. 5.5 I have never tried to used. Now I will be visiting the links you posted. Thanks again.

1 Like

Hi all. I think my issue is solved. OS is not freezing and works very stable. I assume it is result of additional packages I installed according to Radeon suggestions. Meanwhile I found another BIOS version for my laptop that has an option to deny switchable graphic adapters and I will be trying it as rolling back if freeze again. For after almost a week heavy usage of the computer it works perfectly. Thank you for suggestions and support.

2 Likes