Live USB Install - Black Screen on 4K display Fix

Posting this as it may help others and also hoping there will be a resolution from the Zorin team. I don't mind paying for good software/OS so this was a try before I buy type thing.

No matter which option I tried, default install, safe graphics or Nvidia I would always end up with a black screen. Tried disabling/enabling Secure boot, even tried a fresh drive, nothing. And note that this was not an issue with ISO/USB as I was able to successfully install on an older laptop.

I'm not sure where exactly I got the hint (so much googling).. but basically I went down the road of my internal 4K laptop display essentially causing the issue with the installer.

Unfortunately with my laptop (MSI Prestige 15 A10SC) there is no way for it to switch to an external display before an OS launch - no function key press, shutting lid, nothing works. The only thing that finally worked was opening it up and disconnecting the internal monitor. This forced the laptop to use an externally connected display who's native resolution is 1080.

With the laptop and LiveUSB stick booting to the external 1080 display the install worked perfectly. After install I was able to reconnect the internal 4K display and now Zorin 16 Core boots fine so it's just the LiveUSB that seems to be the issue.

Hoping this gets fixed as I would like to purchase the full Pro version but I don't really want to have to disconnect my internal monitor everytime I want to install this OS.

Apart from this, looks like a great product! Cheers.


Excellent post dude! = :star2: :star2: :star2: :star2: :star2: rating

I too have some experience with this. I have my notebook display disabled when in the OS GUI, and I have selected my Nvidia GPU to be used only. For those on Zorin OS, you can do this with the Nvidia Prime extensions.


Thanks @StarTreker! I will check this out.. still just getting into this.. :+1: :+1:

Hey @StarTreker , just curious.. you use this extension to lock your system to use the NVIDIA card... I've been noticing on all flavors of Ubuntu (not limited to Zorin) that my system lags after an hour or two of use.. especially if I have a lot of browser sessions open. Was this something you experienced prior to using this extension to lock the NVidia card in?

Zoom also seems to cause havoc with my system occasionally.

I am using the Nvidia proprietary drives.. 470 I believe.

I don't have any answers, but can attest to Zoom not being great on Linux in general from my experience. My daily driver prior to Zorin was Mint with Cinnamon for years, but have also used Zoom on plenty of others (Fedora, Arch, Manjaro, et) and it has struggled on all of them. Zoom was originally developed for OSX (Unix) so it sees like it working well on Linux would be a shoe in but alas...

Android was originally forked from Linux and uses much of the Linux kernel. Yet, creating an Android emulator or compatibility layer on Linux seems remarkably difficult.

Zoom is oft asked about on the forums.

Hi everyone,
I've also came across with the same issue with my 4K monitor during installation and instead of connecting to an external monitor for installation I found another way that may work for you too.

I have a dell precision 5510 with 4k display.

When you download the ISO file, Open it using an ISO editor like anyburn for windows or unixmen for linux , after that navigate into /boot/grup/grup.cfg on the line 22
change the ' set gfxmode=auto ' into set gfxmode=800×600 or 1366×768.
save the file and make a bootable USB from it.

when you try the installation again it will force the boot into the resolution you set not on what it detects!

Hoping this will fix the issue for you guys like it did for me

1 Like

I have this exact issue..

I followed your advice by using anyburn to edit the grup.cfg file but when I attempt to create a new ISO with the edited grub options I get ANyburn telling me that it has to truncate names and the resulting ISO in no longer bootable.

Any advice on what I'm doing wrong here or an alternate method to edit the file whilst preserving the bootable nature of the ISO ?

there is another way you can try
use rufus
and when you create your bootable device open it and navigate into /boot/grup/grup.cfg and then change the line ' set gfxmode=auto ' into set gfxmode=800×600 and save it!

that should do the trick for you


This worked like a charm, had the desktop up in a test environment in seconds after editing that file mamadian mentions.


Unfortunately it didn't boot, I'm assuming the 4k screen remains the problem. Editing the cfg file on the install media worked for the installation but as soon as I tried to restart, it gave my the same black screen :frowning:

@Mamadiam , you're a legend! Thanks so much... this is a much simpler fix! I did not know about this setting in the cfg file. It's funny because another fix I received for an Ubuntu install involved grabbing an older grub version.. and now that I see this it was likely a fixed setting like this in the cfg file.

Either way, I've had this issue with Zorin and Elementary. Most recently I tried PopOS and my disconnecting monitor cable did not even work for it for some reason, and then I came back here and read your post. This fixed my issue right away, so I suspect I can apply this same fix to the Zorin and Elementary live USBs to fix the issue.

I'm surprised this isn't more well known.. 4K laptop displays are pretty common now I would say.

In any case, thanks for the great and simple fix!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.