Need help booting into Zorin

Hi, so I was able to finally get through the initial boot screen on my Dell XPS 9550 4K monitor by tweaking the grub.cfg file from 'set gfxmode=auto' into 'set gfxmode=800×600' in /boot/grup/grup.cfg by using UNetbootin to make the live USB editable, I thought I was in the clear but then got this screen, which I don't know how to resolve.


  1. Live USB Install - Black Screen on 4K display Fix - #7 by Mamadiam
  2. system installation - Kernel panic when booting from USB stick to install 7 - elementary OS Stack Exchange

I currently have a dual boot setup with Ubuntu and Windows, and I'm just trying to test Zorin to make a decision if I would like to install it over the current two OS'es or if will decided to partition a bulk of my hard drive and make Zorin my daily driver.

Please help.

Please type exit at that screen, then relay what follows on that screen.

No luck getting to boot.

What do you think could be going on?

When booting from the usb drive, does it have " TRY " & " Install Zorin " at the start?
I know with Zorin Core & Lite free versions have this option.
Do you have Zorin Pro?

Also can you tell us about your pc setup.

I manage to get to this boot screen then I click try or install with nvidia drivers…

I have a Dell XPS 9550, 16 gb RAM, intel graphics with nvidia 960m, 1 TB sdd with dual boot Ubuntu and windows 11. If I like Zorin, I’ll either wipe both and do a clean install over the other two or partition most of my disk space for Zorin in case I get stuck like this again…

Is Windows currently installed on that Drive?
You may need to go into control panel and power settings, then turn off Fast Boot or Fast Startup.


Great click enter to " try or Install Zorin os.
Then you'll see 2 icons " TRY " & " Install", select "TRY" under the icon.
Lets see if helps,

Also try disabling " Fast boot " in you BIOS.
Sorry for laptop follow above post by @Aravisian

For reference: Before you install

As a 'side-tip' I would advise you NOT to use Unetbootin anymore. It is a dead project todays, and most: it can't handle modern ISO's not really well.
Use Balena Etcher as app-image or use Gnome imagewriter instead. If it is on Windows you use it: use RUFUS instead.

This can save you from a lot of trouble in the first place or step.

Can you please support this?
Geza Kovacs has been active, and while the latest release is Feb of last year, long periods of time can pass when little needs to be changed.
Unetbootin works fine on "modern" .iso - what makes you believe it does not? Do you have some basis for saying so?
Were you thinking of MulitBoot project?

I actually recommend avoiding Balena Etcher due to a very long standing history of it bricking USB Sticks, for which the Balena Etcher team has constantly shifted the goal posts on any responsibility for.

Schermafdruk van 2023-03-09 17-01-48

Dead, over and out thus. 2021 is now 2 years ago I think. No .deb will install out of missing GPG-key, so it is on full risk via the tar.gz now

There was another Topic in this Forum, recently, where Unetbootin made a 'unbootable stick' of Zorin and Mint even.

I use Balena every day on the daily built testing of the new Ubuntu-installer of Lunar Lobster (23.04 pre-alpha stage now). So every daily built is going over the stick. Balena was b.t.w. advised by Zorin I read somewhere lol. Anyhow I skipped Unetbootin a long time ago, and never really turned back.

Understood: Your answer was "No. I just assume it so."

So a couple of things, Fast Startup is disabled since I have disabled hibernation: How to Disable Fast Startup in Windows 10? – TheITBros

I need a .iso writer that will allow me to edit the live USB or somehow how to figure out how to edit the .iso file so that grub.cfg is updated to 800x600. Using Unetbootin is the only one I have discovered so far that will allow the bootable USB to be editable, Balena creates a read-only version of the live USB.

As mentioned I'm currently using my dual boot to be in Ubuntu 18.04 which seems to be the only version of that distro that works since when I try to boot with a live USB into 22.10 I get an error out of memory and then kernel panic message. So not sure what's going on, but feeling really stuck without really knowing what more I can try since I have done all the basics per before you install link.

This looks just like this Grub Bug:

Agree. I use the Windows version to create live USB's. OK Unetbootin 702 has been out for some months, but it and its previous version have never failed me. It remains my go-to USB creation tool.

Hi all, first off thanks for the suggestions so far. Here's the update, I have been able to boot in 15.3, but I get the same black screen after USB boot when trying to upgrade to 16.2. I believe I'm having the same error as Mamadian Live USB Install - Black Screen on 4K display Fix - #7 by Mamadiam but I'm not able to edit the downloaded .iso file as I constantly get read only errors when trying to adjust the 'set gfxmode=auto ' into set gfxmode=800×600 in /boot/grup/grup.cfg

I've tried what's suggested by Mamadian, but I constantly come up with the .iso being read-only. Does anyone have a sure fire way to make the .iso I'm getting directly from Zorin to tweak the .cfg file to the updated setting?

Actually - before doing that, have you updated your BIOS Firmware?

I’m on the latest firmware available for XPS 15 9550… Version 1.14.0

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.