Locking up / freezing on micro PC

Not sure if general help or installing best fit, I think general as I did manage to get Zorin lite installed 2-3 times and it was a short while before it locked up/ froze

Purchased a micro PC, intel n95 I think.

It has no ps/2 connectors, shouldn’t be an issue but worth remarking on.

I installed Zorin lite 16.3 after wiping off the windows OS

I find it keeps locking up/ freezing, thinking it is the new PC faulty
also I ran memtest 86+ and it passed that.

I reinstalled windows again, this doesn’t lock up.

Ran Zorin as a live USB and it locks up.

Reinstalled Zorin again, locks up.

Reinstalled windows works fine.

Installed Linux Mint, doesn’t lock up but screen resolution as VGA!

Installed Linux Mint Edge doesn’t lock up and screen resolution better

but I don’t like the look of it (Cinnamon)

so I have now installed Solas Budgie

this also appears to work, as all other devices I use use Zorin I would prefer to use Zorin on this new micro PC.

all I can think of is it is something to do with the kernel so I would appreciate some feedback as to if you also think this is due to the older kernel being used?

Then I might try to upgrade the kernel to a newer version

If that doesn’t work I might have to stick with Solas Budgie, which will be a bit of a pain as I try to keep all devices the same.

Looking forward to some good advice!

Once you install Zorin OS, you can boot into it and immediately upgrade the kernel using the TuxInvader repository:

sudo add-apt-repository ppa:tuxinvader/lts-mainline

sudo apt update && sudo apt install linux-generic-6.03

Is this a NUC?

https://www.intel.com/content/www/us/en/support/articles/000030985/intel-nuc.html

In respect of lockups freezing it advises disabling Intel iGD in the BIOS.

1 Like

Yes it is a NUC, but there is no setting in the BIOS for disabling the iGD, thanks for the info though

I tried this kernel upgrade and now it doesn't even boot into zorin!
This is the boot errors prior to kernel upgrade

-- Logs begin at Sat 2023-11-11 12:49:23 GMT, end at Sat 2023-11-11 13:13:54 GMT. --
Nov 11 13:13:23 master-Default-string kernel: ACPI BIOS Error (bug): Could not resolve symbol [_SB.PC00.TXHC.RHUB.SS01], AE_NOT_FOUND (20210730/dswload2-162)
Nov 11 13:13:23 master-Default-string kernel: ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20210730/psobject-220)
Nov 11 13:13:23 master-Default-string kernel: ACPI BIOS Error (bug): Could not resolve symbol [_SB.PC00.TXHC.RHUB.SS02], AE_NOT_FOUND (20210730/dswload2-162)
Nov 11 13:13:23 master-Default-string kernel: ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20210730/psobject-220)
Nov 11 13:13:23 master-Default-string kernel: usbhid 1-6:1.3: couldn't find an input interrupt endpoint

and this is what is on the screen when it now locks up ....
ACPI BIOS Error (bug): Could not resolve symbol [_SB.PC00.TXHC.RHUB.SS01], AE_NOT_FOUND (20210730/dswload2-162)
ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20210730/psobject-220)
ACPI BIOS Error (bug): Could not resolve symbol [_SB.PC00.TXHC.RHUB.SS02], AE_NOT_FOUND (20210730/dswload2-162)
ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20210730/psobject-220)

At present I have installed Debian 12 which on boot shows a kernel of 6.1.0-13, this works OK, no freeze or lock ups.

So it appears to be just an issue with Zorin.
Looks like I won't be switching over to the micro PC at the present.
Still looking on the bright side it gives me time to look at other linux distro's.

I'll leave this open for a short while longer to see if anyone else has some ideas for me to try.

Can't resolve the Zorin issue but you could try:

MX-Linux 23.1 KDE
MX-Linux xfce/fluxbox

https://mxlinux.org/blog/mx-23-1-libretto-released/

Antix 23 (ice-wm)
https://antixlinux.com/

Devuan

1 Like

If the newer kernel did not work, just launch the Grub Menu, select the earlier kernel to boot into. Then remove the later kernel.

sudo apt remove --purge linux-generic-6.03

Thanks for the info, but I'd already reinstalled zorin again, which still still locked up /froze up. I'll have to try some other OS'es for now.

I'll will have a look at those other OS'es, thanks.

It's asolution of sort's for now so I'm going to close this post.

Newer kernel works for me - how do I move it to the Zorins default in regular start-up. right now it defaults to the 5 15 88 gen . TY

Zorin OS will automatically boot to the highest kernel by default.

Not so far - every time I reboot from this I get 5.15.88 - now going into other selections - I can choose it, but so far it has not defaulted to it.

OK I rebooted again and choose Zorin with options choosing the regular gives me the latest, however, I have the 5.15.88 with it's own boot menu selection also. A locked kernel - perhaps - any way to unlock and update it, then I could save the choices menu for options down the road.
TY

Well a kernel can be locked by the grub menu or apt-mark command. Without knowing which you performed it would require explanation of both (forgive me I just don't have the time right now).

Updates don't lock kernels, so I'm thinking you added something to grub that can be removed.

@ERZ, you can check with

cat /etc/default/grub

I got -

ez@ez-SEi:~/Desktop$ cat /etc/default/grub

If you change this file, run 'update-grub' afterwards to update

/boot/grub/grub.cfg.

For full documentation of the options in this file, see:

info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
GRUB_CMDLINE_LINUX=""

Uncomment to enable BadRAM filtering, modify to suit your needs

This works with Linux (no patch required) and with any kernel that obtains

the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)

#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

Uncomment to disable graphical terminal (grub-pc only)

#GRUB_TERMINAL=console

The resolution used on graphical terminal

note that you can use only modes which your graphic card supports via VBE

you can see them in real GRUB with the command `vbeinfo'

#GRUB_GFXMODE=640x480

Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux

#GRUB_DISABLE_LINUX_UUID=true

Uncomment to disable generation of recovery mode menu entries

#GRUB_DISABLE_RECOVERY="true"

Uncomment to get a beep at grub start

#GRUB_INIT_TUNE="480 440 1"

GRUB_THEME=/usr/share/grub/themes/zorin/theme.txt
ez@ez-SEi:~/Desktop$

Should the grub timeout be 0 repping the newest kernel? sorry for the late response - also.

No. If you set it to 0 seconds, you may be unable to access the Grub Menu if you need to.

ok - how to unlock kernel?

Your grub file does not show it as locked in. And apt mark would only hold it from upgrading, it won't change the boot preference.
I am not sure why your system is defaulting into a lower kernel.

Is the newer kernel fully installed or only partially?
Have you ever installed Grub Customizer?