Log Errors: Failed to load module "canberra-gtk-module" & atk-bridge, & "pixbuf" error

What should i do?

2.) I'm also getting another error, which might be gtk related,

See this link below for more info, I dont know enough about this stuff, for example to troubleshoot without someone supervising me here. I dont have my OS backed up & cant just fool around etc. I have to take things seriously.

Let's deal with the libcanberra issue first. Please follow the instructions for how to fix in Debian/Ubuntu here:

1 Like

Pixbuf stands out to me because it is a python package. Have you tried to install missing system python library package or dependencies for gtk?

Try:
sudo apt update, then sudo apt install python3-gi gir1.2-gtk-3.0
These packages allow users and developers to work with GTK-based applications in Python.

If you specifically need to install pixbuf, canberra-gtk, and atk-bridge, they are typically provided by the GTK development libraries (libgtk2.0-dev or libgtk-3-dev on Debian-based systems). You can install them using:
sudo apt install libgtk-3-dev

1 Like

@swarfendor437 , thanks! I followed the links instructions.
The terminal log results are:
"libcanberra-gtk3-module is already the newest version (0.30-7ubuntu1).
libcanberra-gtk3-module set to manually installed.
The following packages were automatically installed and are no longer required"

AND: "The following NEW packages will be installed:
libcanberra-gtk-module libcanberra-gtk0
0 upgraded, 2 newly installed, 0 to remove and 190 not upgraded."

So there is a libcanberra-gtk3-module and also a libcanberra-gtk-module.

Maybe I had a program that was already installed that was trying to run one of these, but that particular version wasnt installed? similarly how there is python and python3.

@ajo001 , " Have you tried to install missing system python library package or dependencies for gtk?"

I know i've used python for different things. But to answer your question, I dont know if I have. I'm sorry if thats not a good answer. I've done a lot with my zorin OS in the past 6 months, I may've done things I didnt full understand when installing python dependencies, or things that depend on python. See my above comment. I am going to see if that progress in my above comment fixes everything. I will give it 24 hours and I will keep checking the logs.

Isn't this pretty much not upgraded?

1 Like

@Ponce-De-Leon , good question.

2.) @swarfendor437 , @ajo001 , still getting canberra errors, it happens everytime I open flatpak GIMP it appears? see below, and also above error logs:

1 Like

OK. Remove the flatpak version via Software, then download and install the .deb package from here:

https://ubuntu.pkgs.org/22.04/ubuntu-universe-amd64/gimp_2.10.30-1build1_amd64.deb.html

1 Like

Maybe you should make a sudo apt update && sudo apt upgrade to update Your System. Maybe that could lead to a Solution because some Packages get Updates.

But one more Thing: You show these Error-Logs. But the System and the Programs run fine or not?

And because of GIMP: I would try to uninstall the Flatpak Version like @swarfendor437 suggested. Then look if you have still these Error's and then try the .deb Version.

1 Like

@Ponce-De-Leon , thanks for the advice. I have been having issues with my OS, and with GIMP. But also, I'd prefer my logs to not be showing any errors in general, if thats even realistic. Errors can cause the OS to lag & eat up RAM and cause feedback loops that eat up RAM/CPU also.

Also, I will do more research to see if installing the downgraded version of GIMP in .deb form is a good idea.

1 Like

And what for Issues are that? Maybe there is a connection.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.