"Log Message"

What does it mean that?? it was in my "Log Message"

8:13:38 PM kernel: snd_hda_intel 0000:00:1b.0: device 1849:0397 is on the power_save denylist, forcing power_save to 0
8:13:38 PM kernel: input: HDA Intel PCH HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:1b.0/sound/card0/input11
8:13:38 PM kernel: input: HDA Intel PCH HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:1b.0/sound/card0/input11
8:13:38 PM kernel: input: HDA Intel PCH HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:1b.0/sound/card0/input10
8:13:38 PM kernel: input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1b.0/sound/card0/input9
8:13:38 PM kernel: input: HDA Intel PCH Line Out as /devices/pci0000:00/0000:00:1b.0/sound/card0/input8
8:13:38 PM kernel: input: HDA Intel PCH Line as /devices/pci0000:00/0000:00:1b.0/sound/card0/input7
8:13:38 PM kernel: input: HDA Intel PCH Rear Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input6
8:13:38 PM kernel: snd_hda_codec_via hdaudioC0D0: Line=0x1b
8:13:38 PM kernel: snd_hda_intel 0000:00:1b.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])

P.D I have no audio and I fix it creating a script made by myself.
But my question is: what does it mean that?? is it bad?? can I ignore it??

Z16 core

I could be wrong, but this looks to me like your system needs to fallback to a different module due to the one you are trying to use being on the blacklist (or denylist).

This probably relates. Had you done any troubleshooting on your sound issue where you checked the contents of /etc/modprobe.d/blacklist.conf
or other contents of /etc/modprobe.d?
Had you used modprobe to try troubleshooting your issue initially?

No, I've never checked the contents of modprobe.d I copied my script in /etc/profile.d

Let's check.

#This file lists those modules which we don't want to be loaded by
#alias expansion, usually so some other driver will be loaded for the
#device instead.

#evbug is a debug tool that should be loaded explicitly
blacklist evbug

#these drivers are very simple, the HID drivers are usually preferred
blacklist usbmouse
blacklist usbkbd

#replaced by e100
blacklist eepro100

#replaced by tulip
blacklist de4x5

#causes no end of confusion by creating unexpected network interfaces
blacklist eth1394

#snd_intel8x0m can interfere with snd_intel8x0, doesn't seem to support much
#hardware on its own (Ubuntu bug #2011, #6810)
blacklist snd_intel8x0m

#Conflicts with dvb driver (which is better for handling this device)
blacklist snd_aw2

#replaced by p54pci
blacklist prism54

#replaced by b43 and ssb.
blacklist bcm43xx

#most apps now use garmin usb driver directly (Ubuntu: #114565)
blacklist garmin_gps

#replaced by asus-laptop (Ubuntu: #184721)
blacklist asus_acpi

#low-quality, just noise when being used for sound playback, causes
#hangs at desktop session start (Ubuntu: #246969)
blacklist snd_pcsp

#ugly and loud noise, getting on everyone's nerves; this should be done by a
#nice pulseaudio bing (Ubuntu: #77010)
blacklist pcspkr

#EDAC driver for amd76x clashes with the agp driver preventing the aperture
#from being initialised (Ubuntu: #297750). Blacklist so that the driver
#continues to build and is installable for the few cases where its
#really needed.
blacklist amd76x_edac

What is your terminal output of

cat /sys/module/snd_hda_intel/parameters/power_save

sudo nano /sys/module/snd_hda_intel/parameters/power_save

Change that setting to

0

and then ctrl+x to exit, then y key to say yes to save, then the enter key to save as current configuration.
Reboot and test.

it doesn't work :c

There is a error writing the file O.o

Try:

echo 0 > /sys/module/snd_hda_intel/parameters/power_save

Then check with the cat command, again (You should be able to up arrow key in your terminal to retrieve it from history, then just hit enter to act on it.

echo 0 > /sys/module/snd_hda_intel/parameters/power_save

zsh: permission denied: /sys/module/snd_hda_intel/parameters/power_save

cat /sys/module/snd_hda_intel/parameters/power_save

1

I change 1 to 0 but when I reboot it return to 1 again

Try:

echo 0 | sudo tee /sys/module/snd_hda_intel/parameters/power_save

then reboot to test or

sudo sysctl -p

There is a file in the same directory called power_save_controller with "Y".
Perhaps this one is of influence on the power_save file, just thinking along.

Fixed it for ya.:grin:

No no my good man, none of such, perhaps your doing it all out of memory. You often have that, remember the dconf editor for the shutter sound.

But both files are named almost the same, I presume they have interfaces.

It doesn't work, it returns to 1 again :c

You make a valid point and maybe I should try looking it up.


Which I just did and found this command:

sudo echo -e '\n# Disable snd-hda-intel power saving\noptions snd-hda-intel power_save=0 power_save_controller=N\n' >> /etc/modprobe.d/alsa-base.conf

The problem is... I am not sure what all that will do...
I mean. O.P. Can try it... What's the worst can happen? LOL

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.