Login password not working

Hey there guys , I am helping my dad for is zorin os . He forgot his password and now not able to get in . I he tried getting into the advance menu but when pressing escape button while booting , it directly takes him to grub terminal with grub and a blinking line . The problem is he is not with me and he is far away and wouldn't be able to come today or next month also and he wants to use the laptop for his office work . Need help pls

Hi,

Unfortunately there is no "password reset" or "forgot password" options available, and your options are very limited once you've been locked of the system.

Installing ZorinOS from scratch would erase the contents of the hard drive and lose all your files in it, but it would restore things back to normal. If you have copies of all important files backed up elsewhere (another computer, external drive or the cloud), then it should be easy enough to get up and running again.

If you don't have backups of important files but the hard drive is not encrypted, you can connect the hard drive to another computer and copy them. Then, re-install ZorinOS and copy the files back.

Having a backup strategy in place is a good thing, and strongly recommend it. Situations like this happen, it could be as innocent as forgetting a password to getting your laptop stolen, or even plain and simple hardware failure (which will happen eventually). I'd suggest following the 3-2-1 rule backup strategy.

2 Likes

Hey thankyou for you time , but he got into the laptop and remembered the password..for now i will tell him to take backup mostly using thunder something something. Itsa a backup app for Linux
.
Regards

I'm glad it all worked out :slight_smile:

Remember, while there are multiple ways and utilities to create backup copies of your data, the most important thing to remember is to store those on separate devices and medias to ensure you can always recover them no matter what.

There is a way to recover password (well not recover, but to reset it), but it does require accessing GRUB menu and choosing the Advanced option, then choosing recovery mode.

Once there you will see a menu and you need to select the Terminal with Root privileges (you won't need a password for this, just Enter to accept).

Then follow this guide:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.