Login to Microsoft with Student Account

As some of you know a Microsoft Account and a Microsoft Student Account are something different. But the functionality stays the same.
There is a way to login if you click onto the field "login using a different method", but this one is not available in the settings menu where you can add accounts.

I want to integrate onedrive into my file explorer. But i cannot login due to my student account. How do i get this funtionality in my file browser?
Thanks in advance

Hi @botch and welcome to our forum :wink:

I have a google account, which is also a school account, and I was able to log in to settings successfully. May I know about your OS version so I can answer accordingly :slightly_smiling_face:

1 Like

Thanks for the quick answer!

I'm using ZorinOS 16 Core

I also have a microsoft school account. trying to sign in :slightly_smiling_face:

I think it's the same problem as login in online.
I can login through the office365 portal although not through the microsoft one.

I was able to sign in on my browser, but not able to sign in settings.

exactly. looks like im not the only one getting this error

Yes. The error message you got in the second picture is the same error which I am getting in settings :slightly_frowning_face:. But I was able to sign in my school google account. Pretty confusing :smiley:

I will try my best. Let me call the other members of this forum, as they may have a solution. Hi @Aravisian, @FrenchPress, @StarTreker, @marko94, I am unable to help @botch for signing in through the student microsoft account. Any idea how to come out of this problem as I am also having the same problem.

I have no idea. But I will speculate a bit and hope it provides a clue someone smarter than I can follow.

Microsoft Account.
On Windows machines, there is Secure Boot which checks a key against a known registration. This is quite similar, actually, to how Linux checks a key against a repository. Except that Linux does not plant it in the hardware.

In order to make Ubuntu function on Secure Boot, Microsoft Windows Signed for Linux for Secure Boot. But not everything was signed, so even so, Secure Boot will mostly work with Ubuntu and Ubuntu derived distros - but not fully.

While this is not a Secure Boot issue, necessarily, it may be very similar. Where you are using a browser or an application that is not signed by Microsoft to allow access.

Again- speculation.

Hi @Aravisian, thank you for your fast reply, but to prevent any confusion, let me tell you in detail. There is an 'Online Accounts' option in settings. But in that, @botch wanted to connect a Student Microsoft Account, so that he can access and sync his school OneDrive with Nautilus. But he is not able to do so as it says "That Microsoft Account doesn't exist". This is also happening with me. I use a google account, so I was able to sign in easily.

Ah! That explains it. You are using GOA.

GOA is not formatted to link with OneDrive.

Let me look for a guide to an alternative...

Ok, found this one:

1 Like

Wow. Thank you so much @Aravisian :wink: I hope @botch can follow these steps.

Let me try to install Onedriver and confirm the same

1 Like

Hi @botch, you can install an app called 'Onedriver' To install it, follow these steps:-
Step 1:- Write these commands turn-by-turn in the Terminal

sudo add-apt-repository ppa:jstaf/onedriver
sudo apt update
sudo apt install onedriver

After running all these commands, you will find an app in your 'Applications' Menu, named 'Onedriver'.

Open it and click on the '+' button on the top-left of the window. It will ask where do you want to access all your onedrive files/mountpoint. Select any empty folder or create a new folder and select it as the mountpoint.

Now, sign-in to your school account. Accept everything and you will be able to access your OneDrive files in the mountpoint ( The place where you selected to access your onedrive files)

Voila! You will be able to access everything properly :wink: (Verified by me :slightly_smiling_face:) Once again thank you @Aravisian for the solution.

Microsoft just equals one giant PITA. I tried to login to my Xbox Live account so that I could play Master Chief Collection on my computer. But Microsoft doesn't have any Linux based APP that allows you to sign into the the Xbox live server like they have on Windows.

And whenever I tried to sign in to the game, it would just fail and error out before I had the chance to input my credentials to complete the sign in process. I eventually realized that Microsoft doesn't want Linux users playing their famous Halo games on PC unless we do it on Windows.

Well, I showed Microsoft where to stick it when I got a refund on Steam. If MS wants to make it impossible, then they don't get my money.

Google kicked me out and refuse to login again, i have to sort this out on linux why it refuse to login.


I have the same issue with my University M$/Office365 account. I couldn't use the logo option. I only really use the email, so I used Exchange to sync email.
Talk to your school IT administrator and see if there's any special setting needed activation on their end too.

@YukKevChuHau please follow these steps and you can login easily.

Thanks for the instructions.

I don't use OneDrive or web-based Office. But, it'll be a good backup if I ever need it.:wink:

1 Like