Logitech External Touchpad not working in OS 17 Pro

I installed Zorin OS 17 Pro and unfortunately my logitech touchpad is not working. I tried to disable and enable the touchpad in the settings. As it is connected via bluetooth I also tried to plug it and use it but it still does not work. The touchpad in my laptop works, just the external touchpad does not.

Try install the touchpad drivers.

sudo apt install xorg-driver-input-synaptics

I already tried but it still doesn't work. It is paired but it doesn't detect it as a touchpad.

Please plug in to USB, open a terminal and enter the command:

lsusb

and post back the results please.

This is the result, thank you!

Looks like it works on some devices and distributions but not all:

I could not see any reference to touchpad in lsusb and made the assumption the touchpad is not the fingerprint reader.

Thank you for your reply. But I'm kinda new to Linux, would you mind telling me how I am to install the link you sent? Thank you!

The link is just a table showing which computer hardware and which Linux Distributions work with that device.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.