Long-good SMB connection now failing

A long-good SMB connection is now failing.
The link smb://pcname.local/sharename was working for the longest time to connect me to a drive on a Windows machine.
Fine. I removed and re-added the connection in Zorin's "Files" making sure to use the correct user ID, workgroup, and password.
I know they are correct since after re-adding the connection and still seeing a failure I reset that info on the host PC!

I am getting the error:
Failed to mount Windows share: INVALID ARGUMENT

If I use the format smb://pcname.local/sharename I do not get asked to log in, there are just a few moments before it fails to that error.

If I use the format smb://pcname/sharename I DO get asked to log in, then it fails.

Connections to the same host/share are working for the Windows PCs on the network.

Thanks all.

Zorin OS 16.3

If it used to work and stopped working, you may need to downgrade the samba client.
What is your current version?

smbclient --version

Odd. I ran "smbclient --version" and got a reply that it was not installed!
Under that, there was a line advising me how to install it, so I did.

I now have smbclient "Version 4.15.13-Ubuntu" installed.
I then tried again to connect to the Windows SMB share but get the same error.

Solution found!
From Terminal reinstalled the cifs utils
I don't know why I had to reinstall the cifs utils, but there you go!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.