Long time Linux Mint user. First time insall of Zorin (17)

I'm a long time Linux Mint user, 10 years plus.

Only recently I discovered Zorin, but I only ever used it in Virtualbox. I admit, I was not too impressed. Too "Ubuntu-e". Rather restrictive and sluggish, even given 8G of ram in a VM.
Roll eyes.....

Anyway, I like to upcycle older machines that no longer perform well using Windows 10+

So, recently, I grabbed a machine from the electrics bin at work. This had a broken battery hatch, no case screws and minus a HDD. A dull thing, an HP-Laptop-15-bw0xx. But still, an amazing find from the IT departments rejects.

So, some fiddling around, installing a meagre 128gb SSD and an 8gb ram upgrade, also some gorilla tape and spare screws, fixed!

Voila! A capable machine!

Or, at least I thought, until I installed Linux Mint 21.2 Cinnamon from scratch (kernel 5.15.0-83), then ran the updates, which installed the kernel update 5.15.0-91.

What a PIG!
It would not accept the kernel update without running at 99% CPU, stalling and freezing on Youtube, then showing a hugely disturbed screen, in a weird broken matrix style, all purple, black and green. Pfffffffff!

This, I must mention, has happened on three other machines lately with that kernel, but funnily enough, it resolved itself when I ran them either in fallback mode or software rendering. After which they have never flickered since (still puzzled).

But, this machine stubbornly refused to play nicely whatever kernel version I tried.

Well, I had spent £14 on an 8g ram card. Damn it!
So I refused to give up.

A spare 4gb USB stick and one Zorin 17 ISO later, and this old wreck is running beautifully. Shame about the onboard webcam though, it is absolute trash.

A fair bit of brain stretching ensued. What a breath of fresh air this exercise has been.

So I've been setting this machine up for about 4 days now (about 8 hours of messing about), and finally, I am happy(ish) with it.

The only thing I have a gripe with is the file manager Nautilus.
Why????? It's a pile of.....
Personally I prefer Nemo, with its customisation, buried in "preferences". But as they say, "Beggars can't be choosers".
I tried installing Nemo as a secondary file manager, which worked, until I found that it borked the update manager. But, one Timeshift later and sorted to back to the default manager.

(Hmmmm....I'm not to sure about replacing Nautilus with Nemo, it's above my pay-grade). Any ideas?


Zorin 17 has found a place in my heart and a new home.
Even my dad cannot go wrong with this machine as a replacement, when his Windows 11 goes pear-shaped, again.

Here's a big "thank you" for the OS, and, a Happy New Year!



I have been using Nemo as my default File Manager on Zorin OS since Zorin OS 12.4
Never had a single conflict with it.
You can set Nemo as default:


Thanks for the reply; re the file manager Aravisian. :+1:

So this whole command should be pasted into the terminal after installing Nemo, no gaps or separated lines? Anything else?

To add to this;
Previously I have installed the Cinnamon desktop environment whilst experimenting with Ubuntu's, then trying gnome extensions, which failed miserably I hasten to add.

I didn't realise there was a Cinnamon environment for Zorin or is it generic? Surely it would affect the eye-candy extensions, such as the desktop cube and burn my windows?

Any way I'm not too fussed about breaking a system that does not require fixing, yet!

Thanks again.

No, if you click on the link to the post, you will see the command separations.

Yes, those are Gnome Extensions and they are exclusive to the Core Desktop that uses Gnome D.E.

I have also installed and used Cinnamon Desktop on Zorin OS and it ran flawlessly. However, it still will not use Gnome Extensions anymore than Linux Mint using it would.
Instead, to burn windows or get the desktop cube, a user would need to install Compiz (Which the Gnome Extensions are based upon).



I just hit the link in your reply and realised that you separate this to three commands.
I'm new to the site (my excuse).

Yeah, compiz the confuser.......I'll leave that for a VM



Compiz can be fun, but I agree it is tangly...

Great. As far as I'm concerned, I now have a better file manager.

It was a bit off a loss not having the options of Home, Computer, Open as root or Terminal in Nautilus. However.......

Ive even got colour folders now, courtesy of ppa Costales. Happy days!!

Happy bunny indeed.

You could go one step further and install Krusader, but you would also need to install Kate. :wink:

There is no loss, here. Gnomes nautilus is needlessly complex with Other locations... > Computer... In Nemo, just hit the Up Arrow Icon you see on your toolbar twice and you are at Root.

For the right click options to Open as Root or Open in terminal in Nemo (I have these both in my Nemo Context Menu, as well):

Run in terminal:

gsettings set org.cinnamon.desktop.default-applications.terminal exec gnome-terminal

I use Zorin OS Lite so Lite users can employ

gsettings set org.cinnamon.desktop.default-applications.terminal exec xfce4-terminal

You can also add a Toolbar button for "Open with terminal" using the below method.

To get open as Root in Nemo:
Click on View > Preferences > Context Menus and select Open as Root.
You can also select the Open In Terminal option, here.

You can also select Open In Terminal.
Per above, you can select Toolbar and select the Open in Terminal.


Thanks for the info, but for a novice like me, I think it would over egging the pudding. I mean, things get confusing, even when using Meld :exploding_head:

Always food for thought though and another VM experiment.

Thanks for all the help buddy and it has been a pleasant experience visiting the forum here today. To be honest, I expected less, especially on New Years Day. A pleasant surprise.

I'll be back picking brains again at some time in the near future. I'm certain of that.




This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.