Looks like there's a mouse pointer bug in the Zorin OS

When I boot ZorinOS Core 17 in the VMware, Mouse pointer is not loading completely.
Please, can you tell me about this bug..?

Can you describe what you are seeing in more detail?
Is the mouse not positioning correctly or not moving correctly?
Is it flashing or blinking?
Is its appearance incorrect?

Mouse is not positioning correctly like below video:

No. My mouse is not showing completely like that video when I boot ZorinOS in VMware.

I want to ask about this problem, and I'll provide an additional video/screenshot if you need it.

From this: The video is able to show it, but your graphics are not showing it?

Are you using a custom mouse theme?

What graphics are you using?

sudo lshw -C video

My mouse is not showing completely.
Also, I'm not using a custom mouse theme.

And this is my VMWare graphic information.

In VMWare, you can try disabling hardware acceleration.

Or, you can try adding export WLR_NO_HARDWARE_CURSORS=1 to your profile file.

I tried "export WLR_NO_HARDWARE_CURSORS=1", but my mouse pointer still not appearing.

I'll wait for your reply, thank you.

I have already posted all I know.:stuck_out_tongue:

I am not a VMWare user and do not know much about VMWare.
But we may be able to help you search for answers:

Understood. I'll reference your provided information,
and thanks for trying to solve my problem.

You can close this ticket. Have a good day.

Is your issue not yet solved?
If not; we should leave this open for now...

Yes... My issue is not yet solved. Sorry.
I'll reply again if this issue is solved.

I am not a VMWare user and do not know much about VMWare.
But we may be able to help you search for answers:

I'm unsure if I solved my problem 100% with this VMWare homepage solution.

One thing is certain, this error message appears when I use ZorinOS.
스크린샷, 스크린캐스트 2024-02-03 23-52-39.webm

If you need some translation, I'll also provide a translation version for you.

I'll wait for your best reply, Thank you.

Yes, if you could. I cannot use a translator on an image file.

Thanks for reply and here's a translation version:

"An error has occurred. Open the Package Manager in the menu that comes up when you right-click it, or run the apt-get command on the terminal to check for the error.
The error message is: 'Error BrokenCount > 0', which usually means that the installed package has an unmet dependency."

(I used Korean Naver papago translator, and you can encounter error sometimes. Please reply again if you can't understand that I translated.)

Open Software & Updates application from the Application Menu and set Download From to Main Server. Close Software & Updates and allow it to refresh.
Once done:
In terminal, please run

sudo apt --fix-missing

sudo apt update && sudo apt install -f

Mhm I understood what you said. Thank you.
I'll tell the result after I enter command you provided.

Thanks for your provided information, error message does not appear any more!
Now the error message problem is solved, and we can continue our mouse cursor problem.

1 Like

Where we left off was: