Loss CPU performance issue after waking up on YouTube

Hi, I'm new to the forum. Zorin is great, I'm learning more and more, but... I have a problem with my computer after waking up from sleep.

Namely:
when I wake up the computer and turn on YouTube (the same meeting on Zoom), then the processor performance drops to about 500-700 mHz (even to 400 mHz when I had TLP installed). If I turn off YT, it returns to the original values, i.e. to about 2.3 GHz and jumps in a different range (works properly).
When playing a movie, the graphics work at max performance (950mHz). However, the performance of the processor drops to very low values, which makes it difficult to work.
I had TLP and cpu-freq (CPU Power Manager for Gnome Shell) installed. I uninstalled TLP, disabled CPU Power Manager and it's still the same. After a reboot everything is back to normal. The problem occurs after waking the computer from sleep.
I only noticed this problem with Youtube and Zoom...
YouTube tested on Firefox and Brave.

My computer:
Lenovo IdeaPad C340 (Touchscreen)
processor: Intel Pentium Gold (2.3 GHz, 2 cores, 4 threads)
graphics: Intel Graphics
drive: NVMe
8GB memory
System: newest Zorin OS Core, Win 11 S mode

I will be very grateful for help. I've been looking for a solution for 4 days now, but I haven't found a case like this anywhere. I want to stay with Zorin Os, but this problem bothers me a lot.

I suspect a hardware compatibility issue (Zorin is based on Ubuntu 20.04) and the only Lenovo machines that are certified for Ubuntu 20.04 are listed here. IdeaPad is not one of them:

https:// ubuntu.com/ certified /laptops? q=&limit=133&vendor=Lenovo&release=20.04+LTS

[Had to put spaces in so yo could see my search criteria. Came back with some E numbers and the rest ThinkPads.

Thank you for your response. I have no luck with the computer. My old Lenovo IdeaPad 320 was very slow with Win10, and I had an almost unused Lenovo IdeaPad C340 in my family (the one in question). It's fast with Win11 S mode, but I like Linux, especially Zorin, hence the decision to install it. It's the sleep issue that worries me. I temporarily solved it by extending the sleep time to 1.5 hours - I'm working with an external monitor connected.
Additionally, I had Evolution (mail client) enabled in autostart. I turned it off and now testing. I'm not 100% sure, but I guess it's better with YouTube performance. During the test, the CPU usage behaves as it did right after starting. Will test it again without an external monitor.
I emphasize that the performance problem appears only when you start a YouTube video and enable Zoom video conferencing. In other cases, the processor has full capacity.

Gday @Maciej , Welcome to the community,

Try turning off " fast boot in the BIOS.
Then in windows 11 , goto, Control panel>Hardware & sound>Power Option, In the left panel,Click on " Choose what closing the lid does ".
On this window, Click the blue link " Change settings that are currently unavailable ",
Now Uncheck " Turn on Fast boot Startup "..
Hope this helps :+1:

Also try updates on Zorin.
sudo apt-get updates
then
sudo apt-get upgrade

Note: updates on windows can change things, Like drives, configurations, etc...
Which can make things difficult.

If possible leave Zoom behind. You and those you know could use a far better conference client without the need to install any software. Just use Firefox and go to https://meet.jit.si and setup your own meeting room and password. Also for Android there is Jitsi Meet which can also join meetings setup in a Browser. You can turn encryption on if needed but you won't be able to record if say a training meeting, so to record the meeting you would need to turn encryption off. You can synch with Outlook or Google Calendar if meetings have to be scheduled. Zoom lied about encryption at launch, gladly never used it or ever will do.

unfortunately my client has Zoom (and Teams) and I need Zoom. But thanks for the advice, I'll check it out :slight_smile:

Thank you for the instruction. Unfortunately, there is no Fast Boot option in the BIOS. However, I changed it in Windows as you wrote (since I have Zorin I don't use Win 11 on this computer ;)).
Unfortunately, it didn't help. Everything is still ok when the system is turned on, but after putting it to sleep and waking up there are problems with YouTube (i.e. with a decrease in processor clock speed). In other programs, CPU performance works normally.
I'm wondering if it's a graphics issue. I have the codecs installed (I found the instructions on the forum). However, I am surprised that this happens with a YouTube video (or a Zoom video).
I changed the Upower.conf values for the low and critical battery alerts some time ago, but it doesn't seem to have any effect on my problem?

See if there are any pointers that might help here:

I know I react a little late on this subject !

Open browsers you work with and search for "Hardware Acceleration" - setting option.
Turn on the browser(s) this setting to OFF (revert the standard setting on or enabled).
Reboot the browser(s) and test again on suspension and loading a YT page

Thank you. I did as you wrote - I turned off hardware acceleration in the browser and ... it's much better! I don't have 400-600 MHz anymore, but 1200-1400 and sometimes it jumps to 2300 (max cpu).
Additionally, I installed all the codecs because I had two different packages installed.
However, there is still a little bit left to complete success, e.g. Zoom still lowers the clock to about 500 MHz and stutters terribly.
I will try to increase the SWAP memory as previously advised by @swarfendor437.
Because I didn't say that after installing Zorin I changed the RAM from 4 to 8 GB. I have SWAP set to 2GB. We'll see. I will definitely let you know!
Thank you very much for all the tips! :slight_smile:

2 Likes

Gday @Maciej ,
Thanks for your feed back..
Yes this could be many thing's...

  1. How old is the laptop?
  2. Did it come installed with win 11 or upgraded from ?OS ?
  3. How long since you installed Zorin?
  4. Size of ssd
  5. Has this happened since Zorin install or has it happened over time?

Just capping on a few things so-far,

With the fast boot up after some research, (yes not via BIOS in that model)
Boot into win11, same instructions as above, ( for disabling lid power) but this time in, Control panel>Hardware & sound>Power Option,,, In that window, on the left panel, Click on " Choose what the power buttons do"
In there again click the blue link " to change setting", & Uncheck ", Turn on fast boot startup".... << (underneath should say " This helps start your pc faster after shut down" )
,,,,,,,,,,,,,,,,,

Next after reboot, enter ZorinOS,
In Settings>Power>General,,, "laptop lid",
try changing to suspend, or another option. ( on my OLD Dell xp,, laptop i have ZorinOS lite ( XFCE) it shows in Power mgr, " when laptop lid is closed" with 4 options.)

My main desktop pc is ZorinOS core only! ( was dual boot for the start)
,,,,,,,,,,,,,,

With 8gb ram, it recommended the SWAP be 4gb.
,,,,,,,,,,,,,

Thats enough for 10min's of work for you :smile: WE HAVE MORE TO DO. :smile:
,,,,,,,,,,
Note after any changes reboot not just restart.
,,,,,,,,,

ADDED: a photo of my monitor with heaps of open browser tab's playing from youtube & running video & running a recording studio with cam etc...

Its about 2.2gb without streaming,etc.
As you can see i'm at approx, 30% cpu, & 4-5gb ram. with 6gb cached.
And i'm running
i7 3.4ghz
16gb ram
250ssd.

Linux Zoom:

And just in case you need MS Teams:
https://packages.microsoft.com/repos/ms-teams/pool/main/t/teams/

1 Like

Teams is probably the worst conferencing app out there. Always crashed (the Linux version) whilst communicating with work so I insisted on Jitsi - never had an issue. I am in the UK and helped a forum member in Florida how to reinstate Windows 10 via Chat Window - never lost a connection the 4 hours 'speaking' with them. Colleague at work forgot to turn their end of the meeting room - stayed on for a solid 3 days!

Thank you for the instructions.
Regarding your questions:

  • the laptop is about 3 years old, but it was hardly used before (the battery showed about 40 charging cycles)
  • has pre-installed Windows 10 S (version S, which does not allow you to install anything outside the Microsoft store ;)). Updated to version 11S.
  • Zorin is on this computer for about a week
  • SSD (exactly M.2 NVME) - 125 GB of which about 80 GB for Zorin
  • it's hard to say when it happened, I've had this system too short. But I will expand the thought below**

//////
I did the settings in Windows according to your instructions

/////

In my settings (CORE version) I don't see an option to set the action when the lid is closed. I've seen these options in GNOME Tweak I think.

/////
I currently have SWAP turned off - is that ok??

/////
**
I most likely found a solution to my problem (I'm still testing so I'm not 100% sure).
Namely: in Settings > Displays I had fraction scaling turned on and the value set to 125%. And it looks like that was the cause of the problem. It was puzzling that when using an external monitor, the system worked fine after waking up (the lid was closed). However, when I opened it to use the laptop screen (as a second, smaller screen), the performance with YouTube turned on dropped to a minimum.
So I think I didn't have fractional scaling enabled when using an external monitor (which didn't cause YouTube issues). The problem, however, was caused by turning on the laptop screen with 125% scaling enabled.
After turning off the YoTube scaling, it runs smoothly, the clock speed of the processor changes in different ranges, although after turning on the laptop, the clock speed is around 2300 MHz, while after waking up around 1400-1800, sometimes it reaches 2300 I monitor it using the CPU-X program.
As I mentioned - I will test it again, for now it looks like it (fractional scaling) could be the problem. Anyway, there is a message next to this option about possible problems.
I will test and let you know.
Thank you all very much for your help and commitment

1 Like

Yes, wrong DPI on monitors can play havoc, i also have on had ZorinOS for 5-6weeks, & learnt about the scaling via tinkering :smile: ..

Your one step ahead of me :+1: I was going to suggest " cpu-x " i had it on windows aswell, ( did you try the benchmark in CPU-X?

Next was disable hardware acceleration in browser ,

also run the update on ZorinOS.

I recommend removing windows,& Clean install ZorinOS,
EG: i have 4-5 programs that i have installed since new,,, & have 39gb on ssd used... 17% of 250gb drive.
If you have both OS on your laptop ( appprox 60gb for each OS,, I'm saying your drive must be getting full,,( you may find ZorinOS Lite may be more suited to that pc?)
So living on the edge ....( with that setup)

Ok also look at startup programs,, in-case you have programs running at startup,,, remove & start a program when needed...
if possible can you screenshot your systems monitor,

Also, Yes try Zorin Tweaks ( in ZorinOS Lite it has the close lid opposition, standard.)

Note: If you have not had any updates, I've had 3-4 in past week,
Run a cleanup..
sudo apt autoremove
then
sudo apt purge.
may free up some space..
then,
sudo apt update
then sudo apt upgrade

Note: After installs or update's ,, Reboot the pc..

I would advise that you have Swap at 4gb,,,
as you see in my photo in above post,,, i was using 4gb/6gb cached,, with 16gb RAM, So by having SWAP, it will be used as a buffer,,
Best practise is to upgrade the RAM if possible,
See where your at....
,,,,,,
Also at 40% battery, your laptop could do funny things, on wakeup. Best on power.
I would also check if your laptop likes having a 2nd monitor,, like power/compatibility/etc.
,, ,,,
It may just be updates aswell.
Make sure you have the 2nd monitor plugged in before running updates, ( sometimes as a new OS install you will have may updates :smile:

Hope you fix it :+1:

1 Like

Just adding,, if your screen text is small... Use the accessibility's ,, Settings>Accessibility>Large Text. you can have it in your taskbar by enabling " Always Show Accessibility Menu", it also has a Zoom ( magnify )..
When trying thing's i also had my screen set to 125% & when i played a video full-screen,, it lost it's mind hahahaha.

Hi,
sorry for the late reply.
As I wrote, I tested the system after changing the fractional scaling in the screen settings.
The tests were successful, i.e. the laptop after waking up (even after about 12 hours) no longer causes problems with YouTube, Zoom also works well :slight_smile: :slight_smile: :slight_smile:
The clock speed of the processor works dynamically, HD movies work smoothly (although I notice a slight frame-rate in some moments, but it does not bother).
As for SWAP - after restarting, SWAP turned on by itself (still 2 GB), but according to the suggestions, I will change it to 4 GB.

One more word about battery life - I noticed that after uninstalling TLP and cpu-freq, the battery lasts about the same amount of time (of course it depends on whether I'm watching movies or just browsing or working on a document).

I believe the problem is solved :slight_smile:
THANK YOU SO MUCH for all your help and suggestions! :slight_smile:

Good to hear :+1: ,
Yes sometimes it's a little bit of everything.
Please Mark the Topic as "Solution" to help others Know. :+1: